summaryrefslogtreecommitdiff
path: root/package/stress-ng
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@gmail.com>2016-09-07 22:21:23 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-09-07 23:01:39 +0200
commit5609fe65aa7a3b85f1226f57439abd07a2869fae (patch)
tree9da6acef810f0b3d25a4b8468e603994369aa2d8 /package/stress-ng
parentada5d835011b335ad2cb3c4f6d50e185cc0973cd (diff)
package/stress-ng: fix install commande
Don't use make install otherwise stress-ng will be rebuild without required link libraries if any. Furthermore, using INSTALL allow to set the file permission correcly on the target. Fixes: http://autobuild.buildroot.net/results/bba/bba4d0b635ab6849f969b8a0363ebe9f5fafd82e Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/stress-ng')
-rw-r--r--package/stress-ng/stress-ng.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/stress-ng/stress-ng.mk b/package/stress-ng/stress-ng.mk
index 6015a1e9e..e12895a67 100644
--- a/package/stress-ng/stress-ng.mk
+++ b/package/stress-ng/stress-ng.mk
@@ -15,8 +15,11 @@ define STRESS_NG_BUILD_CMDS
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
endef
+# Don't use make install otherwise stress-ng will be rebuild without
+# required link libraries if any. Furthermore, using INSTALL allow to
+# set the file permission correcly on the target.
define STRESS_NG_INSTALL_TARGET_CMDS
- $(TARGET_CONFIGURE_OPTS) $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
+ $(INSTALL) -m 0755 -D $(@D)/stress-ng $(TARGET_DIR)/usr/bin/stress-ng
endef
$(eval $(generic-package))