summaryrefslogtreecommitdiff
path: root/package/sunxi-mali
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-02-04 16:36:18 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-04 18:10:15 +0100
commit12d150727a8dff2d6a4c3013936c27fe71ce588d (patch)
treeb5c627479cfaa513b66a77431bb9185b007355cf /package/sunxi-mali
parentdcd0b3cc7b585835a9f4fb76264919946456dcaf (diff)
Strip *.so* and not only executable files
Our current stripping strategy requires that shared libraries have the executable permission. However, this is by far not something recognized as a standard behavior: Debian/Ubuntu distributions for example do not have executable permissions on their libraries. Therefore, pushing to upstream packages fixes that add the executable permissions is not easy. As a result, this commit improves the stripping logic so that it not only strips the files that are executable, but also the ones that match '*.so*', which should match both the shared libraries and the dlopen()'able plugins, as long as they have a .so extension. Thanks to this addition, a number of manual "chmod +x" done by various packages can be removed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/sunxi-mali')
-rw-r--r--package/sunxi-mali/sunxi-mali.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/package/sunxi-mali/sunxi-mali.mk b/package/sunxi-mali/sunxi-mali.mk
index d9fd8be25..c625c6ef7 100644
--- a/package/sunxi-mali/sunxi-mali.mk
+++ b/package/sunxi-mali/sunxi-mali.mk
@@ -68,8 +68,6 @@ endef
define SUNXI_MALI_INSTALL_TARGET_CMDS
$(SUNXI_MALI_MAKE_ENV) $(MAKE) -C $(@D)/lib \
$(SUNXI_MALI_MAKE_OPTS) DESTDIR=$(TARGET_DIR) install
- # add execution permissions so that libraries are properly stripped
- chmod +x $(addprefix $(TARGET_DIR)/usr/lib/lib,EGL.so GLESv1_CM.so GLESv2.so Mali.so UMP.so*)
$(if $(BR2_PACKAGE_SUNXI_MALI_DBG),
$(INSTALL) -m 755 $(@D)/version/version $(TARGET_DIR)/usr/bin/maliver; \
$(INSTALL) -m 755 $(@D)/test/test $(TARGET_DIR)/usr/bin/malitest