summaryrefslogtreecommitdiff
path: root/package/swupdate
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2015-10-03 17:06:46 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-10-03 17:06:46 +0200
commitd6d1848c89afd0001b5419f5f1e8983c6cf83b91 (patch)
tree38a74b568d9b9e11e47ad6ca4f53920bb55e8393 /package/swupdate
parent02d9a379f4faaa71752ccef4c5437a64e7b05af7 (diff)
swupdate: provide sensible error message if no config file is specified
Similar to how we do it for the other kconfig packages. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/swupdate')
-rw-r--r--package/swupdate/swupdate.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/swupdate/swupdate.mk b/package/swupdate/swupdate.mk
index 86bbf1431..9338fc83c 100644
--- a/package/swupdate/swupdate.mk
+++ b/package/swupdate/swupdate.mk
@@ -103,4 +103,12 @@ define SWUPDATE_INSTALL_TARGET_CMDS
cp -dpf $(@D)/www/* $(TARGET_DIR)/var/www/swupdate)
endef
+# Checks to give errors that the user can understand
+# Must be before we call to kconfig-package
+ifeq ($(BR2_PACKAGE_SWUPDATE)$(BR_BUILDING),yy)
+ifeq ($(call qstrip,$(BR2_PACKAGE_SWUPDATE_CONFIG)),)
+$(error No Swupdate configuration file specified, check your BR2_PACKAGE_SWUPDATE_CONFIG setting)
+endif
+endif
+
$(eval $(kconfig-package))