summaryrefslogtreecommitdiff
path: root/package/systemd
diff options
context:
space:
mode:
authorGabe Evans <gabe@hashrabbit.co>2016-07-01 23:51:01 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-02 12:26:54 +0200
commit868de4fc4c885dab23a658690e25b7eeef8605f5 (patch)
tree89f8d2bf190befd79887ae4e626e878faeb53e81 /package/systemd
parentb7f4d933b1c2e469a07b0212a50ac829ab51634f (diff)
package/systemd: add optional support for tmpfiles
Signed-off-by: Gabe Evans <gabe@hashrabbit.co> [Maxime: Add default y] Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/systemd')
-rw-r--r--package/systemd/Config.in11
-rw-r--r--package/systemd/systemd.mk6
2 files changed, 17 insertions, 0 deletions
diff --git a/package/systemd/Config.in b/package/systemd/Config.in
index 324e88448..df1a42894 100644
--- a/package/systemd/Config.in
+++ b/package/systemd/Config.in
@@ -131,6 +131,17 @@ config BR2_PACKAGE_SYSTEMD_QUOTACHECK
http://www.freedesktop.org/software/systemd/man/systemd-quotacheck.service.html
+config BR2_PACKAGE_SYSTEMD_TMPFILES
+ bool "enable tmpfiles support"
+ default y
+ help
+ systemd-tmpfiles creates, deletes, and cleans up volatile
+ and temporary files and directories, based on the
+ configuration file format and location specified in
+ tmpfiles.d(5).
+
+ http://www.freedesktop.org/software/systemd/man/systemd-tmpfiles.html
+
config BR2_PACKAGE_SYSTEMD_NETWORKD
bool "enable network manager"
help
diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index c0503ae92..779d7c51e 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -159,6 +159,12 @@ else
SYSTEMD_CONF_OPTS += --disable-quotacheck
endif
+ifeq ($(BR2_PACKAGE_SYSTEMD_TMPFILES),y)
+SYSTEMD_CONF_OPTS += --enable-tmpfiles
+else
+SYSTEMD_CONF_OPTS += --disable-tmpfiles
+endif
+
ifeq ($(BR2_PACKAGE_SYSTEMD_NETWORKD),y)
SYSTEMD_CONF_OPTS += --enable-networkd
define SYSTEMD_INSTALL_RESOLVCONF_HOOK