summaryrefslogtreecommitdiff
path: root/package/systemd
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-03-29 20:00:20 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-03-29 20:00:20 +0200
commitf5a56880ad651c8ad5e50e89ed3472fa1b81a643 (patch)
tree5de7e325312ca09ddfa47e5b912d60aeed7da7c9 /package/systemd
parent4a6602f77cfe429d1dfc4f36964240b7d4410c54 (diff)
systemd: fix build with libgcrypt enabled
When gcrypt support is enabled, we need to tell systemd where libgpg-error is installed. Fixes: http://autobuild.buildroot.org/results/1fd6193ff33250565c95e53614f5aa7fc6f4581c/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/systemd')
-rw-r--r--package/systemd/systemd.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index 79e657e5f..75ad961d5 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -115,7 +115,8 @@ ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
SYSTEMD_DEPENDENCIES += libgcrypt
SYSTEMD_CONF_OPTS += \
--enable-gcrypt \
- --with-libgcrypt-prefix=$(STAGING_DIR)/usr
+ --with-libgcrypt-prefix=$(STAGING_DIR)/usr \
+ --with-libgpg-error-prefix=$(STAGING_DIR)/usr
else
SYSTEMD_CONF_OPTS += --disable-gcrypt
endif