summaryrefslogtreecommitdiff
path: root/package/targetcli-fb
diff options
context:
space:
mode:
authorChristophe Vu-Brugier <cvubrugier@fastmail.fm>2015-09-03 09:55:26 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-10-03 14:21:07 +0200
commitc6ff869eee978eb82ae740c60a7282860a300d9d (patch)
treeefe4bb8486980eaa95cc6c0f451b00732a97e7d1 /package/targetcli-fb
parent9829b82caf2b5d5479da5f1c16a474466ab104d4 (diff)
targetcli-fb: systemd support
The systemd service file is taken from Fedora. Signed-off-by: Christophe Vu-Brugier <cvubrugier@fastmail.fm> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/targetcli-fb')
-rw-r--r--package/targetcli-fb/target.service14
-rw-r--r--package/targetcli-fb/targetcli-fb.mk8
2 files changed, 21 insertions, 1 deletions
diff --git a/package/targetcli-fb/target.service b/package/targetcli-fb/target.service
new file mode 100644
index 000000000..400284edd
--- /dev/null
+++ b/package/targetcli-fb/target.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Restore LIO kernel target configuration
+Requires=sys-kernel-config.mount
+After=sys-kernel-config.mount network.target local-fs.target
+
+[Service]
+Type=oneshot
+RemainAfterExit=yes
+ExecStart=/usr/bin/targetctl restore
+ExecStop=/usr/bin/targetctl clear
+SyslogIdentifier=target
+
+[Install]
+WantedBy=multi-user.target
diff --git a/package/targetcli-fb/targetcli-fb.mk b/package/targetcli-fb/targetcli-fb.mk
index 0a64c4651..cf7f29ff4 100644
--- a/package/targetcli-fb/targetcli-fb.mk
+++ b/package/targetcli-fb/targetcli-fb.mk
@@ -12,7 +12,13 @@ TARGETCLI_FB_SETUP_TYPE = setuptools
TARGETCLI_FB_DEPENDENCIES = python-configshell-fb python-rtslib-fb python-six
define TARGETCLI_FB_INSTALL_INIT_SYSV
- $(INSTALL) -m 0755 -D package/targetcli-fb/S50target $(TARGET_DIR)/etc/init.d/S50target
+ $(INSTALL) -m 0755 -D package/targetcli-fb/S50target \
+ $(TARGET_DIR)/etc/init.d/S50target
+endef
+
+define TARGETCLI_FB_INSTALL_INIT_SYSTEMD
+ $(INSTALL) -m 0644 -D package/targetcli-fb/target.service \
+ $(TARGET_DIR)/usr/lib/systemd/system/target.service
endef
# Targetcli stores its configuration in /etc/target/saveconfig.json