summaryrefslogtreecommitdiff
path: root/package/taskd
diff options
context:
space:
mode:
authorBen Boeckel <mathstuf@gmail.com>2016-03-09 21:38:40 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-03-10 23:29:58 +0100
commitbd3cbf3e564e890f7fe08aab5c8fa7b8beccff10 (patch)
tree878b5ea30321ca8fdb1f34cd27a0e3f5937fbc21 /package/taskd
parent348d5edd91abec1fc4cc27965220d54e58217dc3 (diff)
taskd: new package
Taskwarrior is a task management suite of tools. Taskd is the synchronization server for it. Signed-off-by: Ben Boeckel <mathstuf@gmail.com> [Thomas: - use 'depends on' for BR2_USE_MMU, and add a comment indicating that the dependency is due to the use of fork() - use 'depends on' for BR2_USE_WCHAR, and add a comment indicating that the dependency is due to gnutls and util-linux. - add a hash file.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/taskd')
-rw-r--r--package/taskd/Config.in15
-rw-r--r--package/taskd/taskd.hash4
-rw-r--r--package/taskd/taskd.mk14
3 files changed, 33 insertions, 0 deletions
diff --git a/package/taskd/Config.in b/package/taskd/Config.in
new file mode 100644
index 000000000..28361612e
--- /dev/null
+++ b/package/taskd/Config.in
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_TASKD
+ bool "taskd"
+ depends on BR2_USE_WCHAR # gnutls, util-linux
+ depends on BR2_USE_MMU # fork()
+ select BR2_PACKAGE_GNUTLS
+ select BR2_PACKAGE_UTIL_LINUX
+ select BR2_PACKAGE_UTIL_LINUX_LIBUUID
+ help
+ Task management synchronization daemon.
+
+ http://taskwarrior.org/
+
+comment "taskd needs a toolchain w/ wchar"
+ depends on BR2_USE_MMU
+ depends on !BR2_USE_WCHAR
diff --git a/package/taskd/taskd.hash b/package/taskd/taskd.hash
new file mode 100644
index 000000000..41d37bbad
--- /dev/null
+++ b/package/taskd/taskd.hash
@@ -0,0 +1,4 @@
+# From http://taskwarrior.org/download/
+sha1 ded339deeee65277e4712f71a9159502f8b20b52 taskd-1.1.0.tar.gz
+# Locally calculated
+sha256 7b8488e687971ae56729ff4e2e5209ff8806cf8cd57718bfd7e521be130621b4 taskd-1.1.0.tar.gz
diff --git a/package/taskd/taskd.mk b/package/taskd/taskd.mk
new file mode 100644
index 000000000..0bdf81d7b
--- /dev/null
+++ b/package/taskd/taskd.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# taskd
+#
+################################################################################
+
+TASKD_VERSION = 1.1.0
+TASKD_SOURCE = taskd-$(TASKD_VERSION).tar.gz
+TASKD_SITE = http://taskwarrior.org/download
+TASKD_LICENSE = MIT
+TASKD_LICENSE_FILES = COPYING LICENSE
+TASKD_DEPENDENCIES = gnutls util-linux
+
+$(eval $(cmake-package))