summaryrefslogtreecommitdiff
path: root/package/tcl
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2016-03-30 17:14:08 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-03-30 19:28:32 +0200
commit36e711c85be980bdbac3499bdc0d2a1f063bf1f3 (patch)
tree4c4bdc167e98183a3bf19b39af2437e5cdd7c6c7 /package/tcl
parent28ccd4d514e5fe7ceca8a4925c241f649890fa69 (diff)
tcl: fix sqlite usage
- Remove the bundled sqlite unconditionally, as we always want to use the external sqlite. - Remove the --with-system-sqlite option as is only valid for the bundled sqlite configure script which we will no longer use. - Do not remove TDBC when BR2_PACKAGE_SQLITE is not selected as it may be used for other TDBC drivers such as MySQL or PostgreSQL. Fixes: http://autobuild.buildroot.net/results/022/02296f8624d3406a63d3a179f53862f245c56dc1/ Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/tcl')
-rw-r--r--package/tcl/tcl.mk12
1 files changed, 4 insertions, 8 deletions
diff --git a/package/tcl/tcl.mk b/package/tcl/tcl.mk
index 10a37c303..817630a04 100644
--- a/package/tcl/tcl.mk
+++ b/package/tcl/tcl.mk
@@ -14,15 +14,10 @@ TCL_SUBDIR = unix
TCL_INSTALL_STAGING = YES
TCL_AUTORECONF = YES
-# Note that --with-system-sqlite will only make a difference
-# in the sqlite package (which gets removed if sqlite not
-# configured). Don't need to worry about conditionally including
-# it in the configure options
TCL_CONF_OPTS = \
--disable-symbols \
--disable-langinfo \
- --disable-framework \
- --with-system-sqlite
+ --disable-framework
HOST_TCL_CONF_OPTS = \
--disable-symbols \
@@ -35,9 +30,10 @@ define HOST_TCL_REMOVE_PACKAGES
rm -fr $(@D)/pkgs/sqlite3* $(@D)/pkgs/tdbc*
endef
HOST_TCL_PRE_CONFIGURE_HOOKS += HOST_TCL_REMOVE_PACKAGES
+
+# We remove the bundled sqlite as we prefer to not use bundled stuff at all.
define TCL_REMOVE_PACKAGES
- rm -fr $(if $(BR2_PACKAGE_SQLITE),,$(@D)/pkgs/sqlite3*) \
- $(if $(BR2_PACKAGE_SQLITE),,$(@D)/pkgs/tdbc1*) \
+ rm -fr $(@D)/pkgs/sqlite3* \
$(@D)/pkgs/tdbcmysql* \
$(@D)/pkgs/tdbcodbc* \
$(@D)/pkgs/tdbcpostgres* \