summaryrefslogtreecommitdiff
path: root/package/tcl
diff options
context:
space:
mode:
authorRichard Genoud <richard.genoud@gmail.com>2013-06-24 10:40:55 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-07-28 16:20:08 +0200
commit8d0413fd370f47014287976f195dc745b95e49d3 (patch)
treee26aa81e5cd4053245246aba7be6c31cd4726428 /package/tcl
parent0b59411c759c8fe97e4edf78a7cd489d5c86ad66 (diff)
tcl: add a tclsh symlink
tclsh is installed with its version number (tclshx.y) but scripts (like usb_modeswitch_dispatcher) are calling tclsh, not tclshx.y. Signed-off-by: Richard Genoud <richard.genoud@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/tcl')
-rw-r--r--package/tcl/tcl.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/tcl/tcl.mk b/package/tcl/tcl.mk
index cc0565c0d..c145f57c2 100644
--- a/package/tcl/tcl.mk
+++ b/package/tcl/tcl.mk
@@ -35,6 +35,11 @@ define TCL_REMOVE_TCLSH
rm -f $(TARGET_DIR)/usr/bin/tclsh$(TCL_VERSION_MAJOR)
endef
TCL_POST_INSTALL_TARGET_HOOKS += TCL_REMOVE_TCLSH
+else
+define TCL_SYMLINK_TCLSH
+ ln -s tclsh$(TCL_VERSION_MAJOR) $(TARGET_DIR)/usr/bin/tclsh
+endef
+TCL_POST_INSTALL_TARGET_HOOKS += TCL_SYMLINK_TCLSH
endif
$(eval $(autotools-package))