summaryrefslogtreecommitdiff
path: root/package/tcl
diff options
context:
space:
mode:
authorAxel Lin <axel.lin@ingics.com>2013-10-14 21:23:02 +0800
committerPeter Korsgaard <peter@korsgaard.com>2013-10-14 22:00:13 +0200
commitb6c0b3b42ab357925d64eb5aa7515f83a7d5ca02 (patch)
tree3bf53930d9984784e7829ebfcc60e4499c2fd857 /package/tcl
parent58712bbe4f085e92962db17d2d4ae34057d9384e (diff)
tcl: specify ln -sf to remove existing destination file
This fixes below build error when executing "make tcl-dirclean; make tcl-rebuild". ln -s tclsh8.4 /opt/test/br-x86/buildroot/output/target/usr/bin/tclsh ln: failed to create symbolic link '/opt/test/br-x86/buildroot/output/target/usr/bin/tclsh': File exists make: *** [/opt/test/br-x86/buildroot/output/build/tcl-8.4.19/.stamp_target_installed] Error 1 Signed-off-by: Axel Lin <axel.lin@ingics.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/tcl')
-rw-r--r--package/tcl/tcl.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/tcl/tcl.mk b/package/tcl/tcl.mk
index 3291c1b28..58f085a20 100644
--- a/package/tcl/tcl.mk
+++ b/package/tcl/tcl.mk
@@ -37,7 +37,7 @@ endef
TCL_POST_INSTALL_TARGET_HOOKS += TCL_REMOVE_TCLSH
else
define TCL_SYMLINK_TCLSH
- ln -s tclsh$(TCL_VERSION_MAJOR) $(TARGET_DIR)/usr/bin/tclsh
+ ln -sf tclsh$(TCL_VERSION_MAJOR) $(TARGET_DIR)/usr/bin/tclsh
endef
TCL_POST_INSTALL_TARGET_HOOKS += TCL_SYMLINK_TCLSH
endif