summaryrefslogtreecommitdiff
path: root/package/tclap
diff options
context:
space:
mode:
authorMatt Weber <matthew.weber@rockwellcollins.com>2014-06-10 19:50:29 -0700
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-06-14 18:56:40 +0200
commit9da3b5d5f9f0fe3fede81178f0bfb3e8ec3f9cef (patch)
treef99a2408991a127d5f7d6842a357a965f0ac2916 /package/tclap
parent68d35f7d92d40f8d470751269e6ee9e398b15a1e (diff)
tclap: new package
Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/tclap')
-rw-r--r--package/tclap/Config.in17
-rw-r--r--package/tclap/tclap.mk16
2 files changed, 33 insertions, 0 deletions
diff --git a/package/tclap/Config.in b/package/tclap/Config.in
new file mode 100644
index 000000000..8c6296fc9
--- /dev/null
+++ b/package/tclap/Config.in
@@ -0,0 +1,17 @@
+comment "tclap needs a toolchain w/ C++"
+ depends on !BR2_INSTALL_LIBSTDCPP
+
+config BR2_PACKAGE_TCLAP
+ bool "tclap"
+ depends BR2_INSTALL_LIBSTDCPP
+ help
+ This is a small, flexible library that provides a simple interface
+ for defining and accessing command line arguments. It was initially
+ inspired by the user friendly CLAP libary. The difference is that
+ this library is templatized, so the argument class is type
+ independent. Type independence avoids identical-except-for-type
+ objects, such as IntArg, FloatArg, and StringArg. While the library
+ is not strictly compliant with the GNU or POSIX standards, it is
+ close.
+
+ http://tclap.sourceforge.net/
diff --git a/package/tclap/tclap.mk b/package/tclap/tclap.mk
new file mode 100644
index 000000000..807f24798
--- /dev/null
+++ b/package/tclap/tclap.mk
@@ -0,0 +1,16 @@
+################################################################################
+#
+# tclap
+#
+################################################################################
+
+TCLAP_VERSION = 1.2.1
+TCLAP_SITE = http://downloads.sourceforge.net/project/tclap
+TCLAP_LICENSE = MIT
+TCLAP_LICENSE_FILES = COPYING
+TCLAP_INSTALL_STAGING = YES
+
+# This package is a pure C++ template library, only made of headers.
+TCLAP_INSTALL_TARGET = NO
+
+$(eval $(autotools-package))