summaryrefslogtreecommitdiff
path: root/package/tcping
diff options
context:
space:
mode:
authorArnaud RĂ©billout <rebillout@syscom.ch>2013-09-13 09:33:58 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-09-13 11:23:41 +0200
commitcccb417e8fb169569561cfa4446e43db714eab36 (patch)
treeb80e20fbc034b2be32546fb7e85a1ebb2d403da8 /package/tcping
parentcd2ff4f637774c2bf7b3d3d11b5e138abf85ef15 (diff)
tcping: new package
tcping does a TCP connect to the given ip/port combination. The user can specify a timeout in seconds. This is useful in shell scripts running in firewalled environments. Often SYNs are just being dropped by firewalls, thus connection establishment will be retried several times (for minutes) until a TCP timeout is reached. With tcping it is possible to check first if the desired port is reachable and then start connection establishment. http://www.linuxco.de/tcping/tcping.html [Peter: wrap help text, pass TARGET_LDFLAGS] Signed-off-by: Arnaud RĂ©billout <rebillout@syscom.ch> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/tcping')
-rw-r--r--package/tcping/Config.in14
-rw-r--r--package/tcping/tcping.mk21
2 files changed, 35 insertions, 0 deletions
diff --git a/package/tcping/Config.in b/package/tcping/Config.in
new file mode 100644
index 000000000..6677b58b7
--- /dev/null
+++ b/package/tcping/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_TCPING
+ bool "tcping"
+ help
+ tcping does a TCP connect to the given ip/port
+ combination. The user can specify a timeout in seconds. This
+ is useful in shell scripts running in firewalled
+ environments. Often SYNs are just being dropped by
+ firewalls, thus connection establishment will be retried
+ several times (for minutes) until a TCP timeout is
+ reached. With tcping it is possible to check first if the
+ desired port is reachable and then start connection
+ establishment.
+
+ http://www.linuxco.de/tcping/tcping.html
diff --git a/package/tcping/tcping.mk b/package/tcping/tcping.mk
new file mode 100644
index 000000000..ff43490c8
--- /dev/null
+++ b/package/tcping/tcping.mk
@@ -0,0 +1,21 @@
+################################################################################
+#
+# tcping
+#
+################################################################################
+
+TCPING_VERSION = 1.3.5
+TCPING_SITE = http://www.linuxco.de/tcping
+TCPING_LICENSE = GPLv3+
+TCPING_LICENSE_FILES = LICENSE
+
+define TCPING_BUILD_CMDS
+ $(MAKE) CC="$(TARGET_CC)" CCFLAGS="$(TARGET_CFLAGS) $(TARGET_LDFLAGS)" \
+ -C $(@D) tcping.linux
+endef
+
+define TCPING_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/tcping $(TARGET_DIR)/usr/bin/tcping
+endef
+
+$(eval $(generic-package))