summaryrefslogtreecommitdiff
path: root/package/tftpd
diff options
context:
space:
mode:
authorKelvin Cheung <keguang.zhang@gmail.com>2014-10-23 19:13:24 +0800
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-23 22:11:44 +0200
commit0659ca799fe0b8945880fb768364a6e7721b132e (patch)
tree2712486c1270f147eab1eb8e8c463c98fc0aeee8 /package/tftpd
parentc638eecc5844fddbb6b1fd5873bf383449b9114e (diff)
tftpd: install TFTP client as well
This patch installs TFTP client as well and overrides BusyBox implementations if BusyBox is enabled. [Thomas: fix typo SYSKLOGD_DEPENDENCIES -> TFTPD_DEPENDENCIES noticed by Baruch.] Signed-off-by: Kelvin Cheung <keguang.zhang@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/tftpd')
-rw-r--r--package/tftpd/tftpd.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/tftpd/tftpd.mk b/package/tftpd/tftpd.mk
index c8457db0b..816a25ec5 100644
--- a/package/tftpd/tftpd.mk
+++ b/package/tftpd/tftpd.mk
@@ -13,7 +13,13 @@ ifneq ($(BR2_INET_IPV6),y)
TFTPD_CONF_OPTS += --without-ipv6
endif
+# Override BusyBox implementations if BusyBox is enabled.
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+TFTPD_DEPENDENCIES += busybox
+endif
+
define TFTPD_INSTALL_TARGET_CMDS
+ $(INSTALL) -D $(@D)/tftp/tftp $(TARGET_DIR)/usr/bin/tftp
$(INSTALL) -D $(@D)/tftpd/tftpd $(TARGET_DIR)/usr/sbin/tftpd
$(INSTALL) -D package/tftpd/S80tftpd-hpa $(TARGET_DIR)/etc/init.d/
endef