summaryrefslogtreecommitdiff
path: root/package/thrift
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-09-27 21:32:44 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-04 18:54:16 +0200
commitaaffd209fae91a733fe0becb72268f87bf4ea369 (patch)
tree40569895ef8a09c605060e2164d86567a12f9889 /package/thrift
parent1d2574ac6f6d30044ee138b6235c50a6a3998d8a (diff)
packages: rename FOO_CONF_OPT into FOO_CONF_OPTS
To be consistent with the recent change of FOO_MAKE_OPT into FOO_MAKE_OPTS, make the same change for FOO_CONF_OPT. Sed command used: find * -type f | xargs sed -i 's#_CONF_OPT\>#&S#g' Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/thrift')
-rw-r--r--package/thrift/thrift.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/thrift/thrift.mk b/package/thrift/thrift.mk
index 0f6a1d08e..e14cb5706 100644
--- a/package/thrift/thrift.mk
+++ b/package/thrift/thrift.mk
@@ -10,9 +10,9 @@ THRIFT_DEPENDENCIES = host-pkgconf host-thrift boost libevent openssl zlib
THRIFT_INSTALL_STAGING = YES
HOST_THRIFT_DEPENDENCIES = host-boost host-libevent host-openssl host-pkgconf \
host-zlib host-bison host-flex
-THRIFT_CONF_OPT = --with-sysroot=$(STAGING_DIR) --with-tests=no \
+THRIFT_CONF_OPTS = --with-sysroot=$(STAGING_DIR) --with-tests=no \
--with-boost=$(STAGING_DIR)
-HOST_THRIFT_CONF_OPT = --with-sysroot=$(HOST_DIR) --with-tests=no
+HOST_THRIFT_CONF_OPTS = --with-sysroot=$(HOST_DIR) --with-tests=no
THRIFT_AUTORECONF = YES
THRIFT_LICENSE = Apache-2.0
THRIFT_LICENSE_FILES = LICENSE
@@ -25,17 +25,17 @@ endif
# Language selection
# The generator (host tool) works with all of them regardless
# This is just for the libraries / bindings
-THRIFT_LANG_CONF_OPT += --without-csharp --without-java --without-erlang \
+THRIFT_LANG_CONF_OPTS += --without-csharp --without-java --without-erlang \
--without-python --without-perl --without-php --without-php_extension \
--without-ruby --without-haskell --without-go --without-d --without-qt4
-HOST_THRIFT_CONF_OPT += $(THRIFT_LANG_CONF_OPT) --without-c_glib
-THRIFT_CONF_OPT += $(THRIFT_LANG_CONF_OPT)
+HOST_THRIFT_CONF_OPTS += $(THRIFT_LANG_CONF_OPTS) --without-c_glib
+THRIFT_CONF_OPTS += $(THRIFT_LANG_CONF_OPTS)
# C bindings
ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
THRIFT_DEPENDENCIES += libglib2
else
-THRIFT_CONF_OPT += --without-c_glib
+THRIFT_CONF_OPTS += --without-c_glib
endif
# De-hardcode THRIFT for cross compiling