summaryrefslogtreecommitdiff
path: root/package/tinyxml2
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@openwide.fr>2015-05-08 12:49:55 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-05-16 14:01:02 +0200
commit0fa452df185545d3781b3015195bee9431496b5d (patch)
tree03038d8a0de761500cc52b280661bab56e7a3000 /package/tinyxml2
parent22f5be171c6f9bb2611e7b87197e9faeabcaab18 (diff)
package/tinyxml2: fix cmake warning
CMake complains about Policy CMP0037 that reserve some target name such "test". So remove the warning by renaming test to xmltest. Backport an upstream patch: 0b2c22bd46be95b08f234b8b4cb262f72ab3f0e8 Signed-off-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/tinyxml2')
-rw-r--r--package/tinyxml2/0002-Rename-test-fixed-cmake-warning.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/package/tinyxml2/0002-Rename-test-fixed-cmake-warning.patch b/package/tinyxml2/0002-Rename-test-fixed-cmake-warning.patch
new file mode 100644
index 000000000..b712f68e7
--- /dev/null
+++ b/package/tinyxml2/0002-Rename-test-fixed-cmake-warning.patch
@@ -0,0 +1,38 @@
+From 77631a9cf500a578338a83bc230c419bf2a05b50 Mon Sep 17 00:00:00 2001
+From: xantares <xantares09@hotmail.com>
+Date: Fri, 14 Nov 2014 19:46:18 +0100
+Subject: [PATCH] Rename test, fixed cmake warning.
+
+Signed-off-by: Romain Naour <romain.naour@openwide.fr>
+---
+ CMakeLists.txt | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4375bb9..4a8f91d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -53,10 +53,10 @@ set_target_properties(tinyxml2 PROPERTIES
+ VERSION "${GENERIC_LIB_VERSION}"
+ SOVERSION "${GENERIC_LIB_SOVERSION}")
+
+-add_executable(test xmltest.cpp)
+-add_dependencies(test tinyxml2)
+-add_dependencies(test ${TARGET_DATA_COPY})
+-target_link_libraries(test tinyxml2)
++add_executable(xmltest xmltest.cpp)
++add_dependencies(xmltest tinyxml2)
++add_dependencies(xmltest ${TARGET_DATA_COPY})
++target_link_libraries(xmltest tinyxml2)
+
+
+ install(TARGETS tinyxml2
+@@ -76,4 +76,4 @@ endforeach()
+ configure_file(tinyxml2.pc.in tinyxml2.pc @ONLY)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/tinyxml2.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+
+-#add_test(test ${SAMPLE_NAME} COMMAND $<TARGET_FILE:${SAMPLE_NAME}>)
++#add_test(xmltest ${SAMPLE_NAME} COMMAND $<TARGET_FILE:${SAMPLE_NAME}>)
+--
+1.9.3
+