summaryrefslogtreecommitdiff
path: root/package/trousers
diff options
context:
space:
mode:
authorZakharov Vlad <Vladislav.Zakharov@synopsys.com>2016-11-22 13:42:25 +0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-23 23:30:38 +0100
commitf4cd8ceb9cfa908f3cdf0fffb94f1c854ddd24c4 (patch)
treef2e4264f19bb6ba8e3cf57cce3b8162d2f837646 /package/trousers
parent171d4103c565d618ac6dfc61dedf3e1a310e8d6c (diff)
trousers: Pass "-mno-compact-casesi" when building for ARCv1
Compact casesi patterns don't have a reload version. This causes build failures of "trousers" package for ARC. Current patch disables compact casesi patterns for ARCv1 (750D and 770D) via passing "-mno-compact-casesi" option when compiling "trousers". This change is a temporary workaround and the feature is going to be fixed in the next ARC toolchain release version. Fixes: http://autobuild.buildroot.org/results/d2c/d2c16d8ba022b070c4dbeba5e7ea41f14d706691// Signed-off-by: Vlad Zakharov <vzakhar@synopsys.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/trousers')
-rw-r--r--package/trousers/trousers.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/trousers/trousers.mk b/package/trousers/trousers.mk
index 3d9e0badc..4fc949909 100644
--- a/package/trousers/trousers.mk
+++ b/package/trousers/trousers.mk
@@ -18,6 +18,10 @@ ifeq ($(BR2_PACKAGE_LIBICONV),y)
TROUSERS_DEPENDENCIES += libiconv
endif
+ifeq ($(BR2_arc770d)$(BR2_arc750d),y)
+TROUSERS_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -mno-compact-casesi"
+endif
+
# The TrouSerS build system attempts to create the tss user and group
# on the host system. Disable the user checking feature as a
# workaround.