summaryrefslogtreecommitdiff
path: root/package/tslib
diff options
context:
space:
mode:
authorMartin Kepplinger <martin.kepplinger@ginzinger.com>2017-02-09 07:55:04 +0200
committerPeter Korsgaard <peter@korsgaard.com>2017-02-09 09:32:09 +0100
commit7794d5f94946d94c2a19913fb88cacfd2b7d3531 (patch)
treeab87caa1e784559539da77a1c7e882c3b329bd55 /package/tslib
parentbfd317e57158f4153c9c01514c54ca4d5e37d2c5 (diff)
Revert "tslib: needs kernel headers 3.12"
This reverts commit 7c60211ce38273580f1f8bf5886771406f9899ca. tslib-1.4 removes this dependency. Add upstream patch that fixes input macros declaration for older kernels. The ts_uinput tool requires 3.6 headers; disable for older kernels. Signed-off-by: Martin Kepplinger <martin.kepplinger@ginzinger.com> [baruch: add tslib patch; disable ts_uinput] Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/tslib')
-rw-r--r--package/tslib/Config.in5
-rw-r--r--package/tslib/tslib.hash2
-rw-r--r--package/tslib/tslib.mk5
3 files changed, 9 insertions, 3 deletions
diff --git a/package/tslib/Config.in b/package/tslib/Config.in
index 366530143..bc5d79018 100644
--- a/package/tslib/Config.in
+++ b/package/tslib/Config.in
@@ -1,11 +1,10 @@
config BR2_PACKAGE_TSLIB
bool "tslib"
depends on !BR2_STATIC_LIBS # dlopen
- depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12
help
Tslib is a filtering layer for touchscreen panel events.
https://github.com/kergoth/tslib
-comment "tslib needs a toolchain w/ dynamic library, headers >= 3.12"
- depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12
+comment "tslib needs a toolchain w/ dynamic library"
+ depends on BR2_STATIC_LIBS
diff --git a/package/tslib/tslib.hash b/package/tslib/tslib.hash
index 6540ac89b..b731df290 100644
--- a/package/tslib/tslib.hash
+++ b/package/tslib/tslib.hash
@@ -1,2 +1,4 @@
# taken from https://github.com/kergoth/tslib/releases/tag/1.4
sha256 ad0373f1dbfda27caec92cb10421227f226c79d160488f1ac915585ba947741f tslib-1.4.tar.xz
+# Locally computed
+sha256 b76d25358d1e2bbcc88b0b225e8d71cd00a4795f6d17020bae270940b17d0825 02795c4fa8b842c6fc017e86b5e036466bd4d3ef.patch
diff --git a/package/tslib/tslib.mk b/package/tslib/tslib.mk
index 5ea526e57..356c4c2d9 100644
--- a/package/tslib/tslib.mk
+++ b/package/tslib/tslib.mk
@@ -10,8 +10,13 @@ TSLIB_SOURCE = tslib-$(TSLIB_VERSION).tar.xz
TSLIB_LICENSE = GPL, LGPL
TSLIB_LICENSE_FILES = COPYING
+TSLIB_PATCH = https://github.com/kergoth/tslib/commit/02795c4fa8b842c6fc017e86b5e036466bd4d3ef.patch
TSLIB_AUTORECONF = YES
TSLIB_INSTALL_STAGING = YES
TSLIB_INSTALL_STAGING_OPTS = DESTDIR=$(STAGING_DIR) LDFLAGS=-L$(STAGING_DIR)/usr/lib install
+ifeq ($(BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_6),)
+TSLIB_CONF_OPTS += --disable-tools
+endif
+
$(eval $(autotools-package))