summaryrefslogtreecommitdiff
path: root/package/tstools
diff options
context:
space:
mode:
authorTzu-Jung Lee <roylee17@gmail.com>2013-07-20 20:52:19 +0800
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-07-27 16:09:38 +0200
commit396e92ed2e2aad55fbb2c0592c7e3f0063e0e065 (patch)
tree2d9755b8d111edf215532316920e38d15f0d99b0 /package/tstools
parent03882d45b2dbf1ed0be759284d812d5f3cf3e917 (diff)
tstools: new package
[Thomas: properly indent help text, add largefile dependency, remove unneeded libpcap dependency, remove unneeded CLEAN_CMDS, reorder build and install commands, remove uneeded <pkg>_INSTALL_STAGING, <pkg>_INSTALL_TARGET and <pkg>_INSTALL_IMAGES variables, move from package/multimedia/ to package/, add license details, rename patch to remove version number in the patch filename.] Signed-off-by: Tzu-Jung Lee <tjlee@ambarella.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/tstools')
-rw-r--r--package/tstools/Config.in17
-rw-r--r--package/tstools/tstools-build-get-along-with-buildroot.patch40
-rw-r--r--package/tstools/tstools.mk21
3 files changed, 78 insertions, 0 deletions
diff --git a/package/tstools/Config.in b/package/tstools/Config.in
new file mode 100644
index 000000000..58f3df1ef
--- /dev/null
+++ b/package/tstools/Config.in
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_TSTOOLS
+ bool "tstools"
+ depends on BR2_LARGEFILE
+ help
+ This is a set of cross-platform command line tools for
+ working with MPEG data
+
+ The emphasis is on relatively simple tools which concentrate
+ on MPEG (H.264 and H.262) data packaged according to H.222
+ (i.e., TS or PS), with a particular interest in checking for
+ conformance.
+
+ Transport Stream (TS) is typically used for distribution of
+ cable and satellite data. Program Stream (PS) is typically
+ used to store data on DVDs.
+
+ http://tstools.berlios.de/
diff --git a/package/tstools/tstools-build-get-along-with-buildroot.patch b/package/tstools/tstools-build-get-along-with-buildroot.patch
new file mode 100644
index 000000000..1e7a74826
--- /dev/null
+++ b/package/tstools/tstools-build-get-along-with-buildroot.patch
@@ -0,0 +1,40 @@
+From 44f80bce0914d4d9c5e7486c7cdb521ba637b324 Mon Sep 17 00:00:00 2001
+From: Tzu-Jung Lee <tjlee@ambarella.com>
+Date: Fri, 19 Jul 2013 22:45:18 +0800
+Subject: [PATCH] build: get along with buildroot
+
+Signed-off-by: Tzu-Jung Lee <tjlee@ambarella.com>
+---
+ Makefile | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 2c3568e..98bb994 100644
+--- a/Makefile
++++ b/Makefile
+@@ -34,12 +34,6 @@ SHELL = /bin/sh
+ .SUFFIXES:
+ .SUFFIXES: .c .o
+
+-ifdef CROSS_COMPILE
+-CC = $(CROSS_COMPILE)gcc
+-else
+-CC = gcc
+-endif
+-
+ # Use WARN=1 periodically to get too many warnings...
+ ifdef WARN
+ WARNING_FLAGS = -Wall -W -Wfloat-equal -Wundef -Wshadow -Wpointer-arith -Wcast-qual -Wconversion -Wmissing-prototypes -Wmissing-declarations -Wunreachable-code -Winline
+@@ -452,3 +446,9 @@ test_lists: $(BINDIR)/test_nal_unit_list $(BINDIR)/test_es_unit_list
+ @echo +++ Testing ES unit lists
+ $(BINDIR)/test_es_unit_list
+ @echo +++ Test succeeded
++
++.PHONY: install
++install:
++ @for i in $(PROGS); do \
++ cp -f $$i $(DESTDIR)/usr/bin/; \
++ done
+--
+1.8.3.2
+
diff --git a/package/tstools/tstools.mk b/package/tstools/tstools.mk
new file mode 100644
index 000000000..377cc34f9
--- /dev/null
+++ b/package/tstools/tstools.mk
@@ -0,0 +1,21 @@
+################################################################################
+#
+# tstools
+#
+################################################################################
+
+TSTOOLS_VERSION = 1_11
+TSTOOLS_SITE = https://tstools.googlecode.com/files/
+TSTOOLS_SOURCE = tstools-$(TSTOOLS_VERSION).tgz
+TSTOOLS_LICENSE = MPL v1.1
+
+define TSTOOLS_BUILD_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
+endef
+
+define TSTOOLS_INSTALL_TARGET_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+ DESTDIR=$(TARGET_DIR) install
+endef
+
+$(eval $(generic-package))