summaryrefslogtreecommitdiff
path: root/package/tstools
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2013-11-12 23:12:33 +0100
committerPeter Korsgaard <peter@korsgaard.com>2013-11-12 23:12:33 +0100
commit7a7ec2dd3758a9832471db2ccf0f8bf7b08ad6dc (patch)
treeda4e82a898eb0aa06319f0558b9a6d1a1273734e /package/tstools
parent3a740799a967592a262b7c9658e9a07f37bf8662 (diff)
tstools: perform shared library linking step using gcc rather than ld
Fixes http://autobuild.buildroot.net/results/c45/c45bbdaff6cff56b5646add38032f29bb5520f16 Using ld directly breaks with certain toolchain configurations. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/tstools')
-rw-r--r--package/tstools/tstools.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/tstools/tstools.mk b/package/tstools/tstools.mk
index 377cc34f9..c9ac9f9c3 100644
--- a/package/tstools/tstools.mk
+++ b/package/tstools/tstools.mk
@@ -10,7 +10,8 @@ TSTOOLS_SOURCE = tstools-$(TSTOOLS_VERSION).tgz
TSTOOLS_LICENSE = MPL v1.1
define TSTOOLS_BUILD_CMDS
- $(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
+ $(TARGET_CONFIGURE_OPTS) LD="$(TARGET_CC)" $(TARGET_MAKE_ENV) \
+ $(MAKE) -C $(@D)
endef
define TSTOOLS_INSTALL_TARGET_CMDS