summaryrefslogtreecommitdiff
path: root/package/tunctl
diff options
context:
space:
mode:
authorSergio Prado <sergio.prado@e-labworks.com>2016-07-23 11:18:50 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-23 22:56:24 +0200
commit689b2b74effc1d112f43f7ee4f21c757a2312e56 (patch)
treef399df25e1813c707caa28636ef40e433c1acc6d /package/tunctl
parentab03eaedf8ba623b10e0c3537dd9afcd32db2b28 (diff)
tunctl: new package
Tunctl is a tool for controlling the TUN/TAP driver in Linux. Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com> [Thomas: use $(TARGET_CONFIGURE_OPTS).] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/tunctl')
-rw-r--r--package/tunctl/Config.in6
-rw-r--r--package/tunctl/tunctl.hash2
-rw-r--r--package/tunctl/tunctl.mk22
3 files changed, 30 insertions, 0 deletions
diff --git a/package/tunctl/Config.in b/package/tunctl/Config.in
new file mode 100644
index 000000000..26eed4c31
--- /dev/null
+++ b/package/tunctl/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_TUNCTL
+ bool "tunctl"
+ help
+ Tunctl is a tool for controlling the TUN/TAP driver in Linux.
+
+ https://sourceforge.net/projects/tunctl/
diff --git a/package/tunctl/tunctl.hash b/package/tunctl/tunctl.hash
new file mode 100644
index 000000000..d3aaeecef
--- /dev/null
+++ b/package/tunctl/tunctl.hash
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256 aa2a6c4cc6bfacb11e0d9f62334a6638a0d435475c61230116f00b6af8b14fff tunctl-1.5.tar.gz
diff --git a/package/tunctl/tunctl.mk b/package/tunctl/tunctl.mk
new file mode 100644
index 000000000..81e6c8cc2
--- /dev/null
+++ b/package/tunctl/tunctl.mk
@@ -0,0 +1,22 @@
+################################################################################
+#
+# tunctl
+#
+################################################################################
+
+TUNCTL_VERSION = 1.5
+TUNCTL_SOURCE = tunctl-$(TUNCTL_VERSION).tar.gz
+TUNCTL_SITE = http://downloads.sourceforge.net/project/tunctl/tunctl/$(TUNCTL_VERSION)
+
+TUNCTL_LICENSE = GPLv2
+TUNCTL_LICENSE_FILES = tunctl.c
+
+define TUNCTL_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) tunctl
+endef
+
+define TUNCTL_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0755 -D $(@D)/tunctl $(TARGET_DIR)/usr/sbin/tunctl
+endef
+
+$(eval $(generic-package))