summaryrefslogtreecommitdiff
path: root/package/tvheadend
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2014-11-16 13:26:26 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-11-18 22:50:54 +0100
commitb0abee37c85b288796dcf7537b6d227833b08f36 (patch)
tree7f632cc24c57f9a9e7564801bfceef183ce52736 /package/tvheadend
parenteca98a10b855692d8ef041c0b95d10b1ad793e05 (diff)
package/tvheadend: add support for host-python3
Added upstream: https://github.com/tvheadend/tvheadend/commit/5a07ff166a84c65f08d326c69c818f6eef315e68 Tested with these defconfigs: BR2_TOOLCHAIN_BUILDROOT_LARGEFILE=y BR2_TOOLCHAIN_BUILDROOT_INET_IPV6=y BR2_TOOLCHAIN_BUILDROOT_WCHAR=y BR2_PACKAGE_PYTHON3=y BR2_PACKAGE_TVHEADEND=y BR2_TOOLCHAIN_BUILDROOT_LARGEFILE=y BR2_TOOLCHAIN_BUILDROOT_INET_IPV6=y BR2_TOOLCHAIN_BUILDROOT_WCHAR=y BR2_PACKAGE_PYTHON=y BR2_PACKAGE_TVHEADEND=y Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/tvheadend')
-rw-r--r--package/tvheadend/tvheadend.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/tvheadend/tvheadend.mk b/package/tvheadend/tvheadend.mk
index 0b564f676..b0038c836 100644
--- a/package/tvheadend/tvheadend.mk
+++ b/package/tvheadend/tvheadend.mk
@@ -8,7 +8,7 @@ TVHEADEND_VERSION = fcd16fa0d835d7fd4f57c350ed8b76350440c68c
TVHEADEND_SITE = $(call github,tvheadend,tvheadend,$(TVHEADEND_VERSION))
TVHEADEND_LICENSE = GPLv3+
TVHEADEND_LICENSE_FILES = LICENSE.md
-TVHEADEND_DEPENDENCIES = host-pkgconf host-python openssl
+TVHEADEND_DEPENDENCIES = host-pkgconf $(if $(BR2_PACKAGE_PYTHON3),host-python3,host-python) openssl
ifeq ($(BR2_PACKAGE_AVAHI),y)
TVHEADEND_DEPENDENCIES += avahi
@@ -42,7 +42,7 @@ define TVHEADEND_CONFIGURE_CMDS
--prefix=/usr \
--arch="$(ARCH)" \
--cpu="$(BR2_GCC_TARGET_CPU)" \
- --python="$(HOST_DIR)/usr/bin/python2" \
+ --python="$(HOST_DIR)/usr/bin/python" \
--disable-dvbscan \
--enable-bundle \
--disable-libffmpeg_static \