summaryrefslogtreecommitdiff
path: root/package/tvheadend
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2015-10-12 22:39:30 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-10-12 23:44:20 +0200
commitea565bf88ebe9e3888264d9d0115c034c1226d9f (patch)
tree486f3d7f2f5c7f30077a1e4e26018011b0a3cd5d /package/tvheadend
parentf640a6659f6c5f9c99684a98de006bbccfded128 (diff)
package/tvheadend: add dbus as optional dependency
Dbus is an optional dependency for tvheadend: https://github.com/tvheadend/tvheadend/commit/9c7b6047d2e3040e14cdba89f46d8acb2a36a115 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/tvheadend')
-rw-r--r--package/tvheadend/tvheadend.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/tvheadend/tvheadend.mk b/package/tvheadend/tvheadend.mk
index 30598055b..4ffb357a5 100644
--- a/package/tvheadend/tvheadend.mk
+++ b/package/tvheadend/tvheadend.mk
@@ -18,6 +18,13 @@ ifeq ($(BR2_PACKAGE_AVAHI),y)
TVHEADEND_DEPENDENCIES += avahi
endif
+ifeq ($(BR2_PACKAGE_DBUS),y)
+TVHEADEND_DEPENDENCIES += dbus
+TVHEADEND_CONF_OPTS += --enable-dbus-1
+else
+TVHEADEND_CONF_OPTS += --disable-dbus-1
+endif
+
ifeq ($(BR2_PACKAGE_FFMPEG),y)
TVHEADEND_DEPENDENCIES += ffmpeg
TVHEADEND_CONF_OPTS += --enable-libav