summaryrefslogtreecommitdiff
path: root/package/unrar
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2016-01-06 09:49:00 -0300
committerPeter Korsgaard <peter@korsgaard.com>2016-02-02 01:02:18 +0100
commit3dd53276b09b857581b03e65857339cdc0e6e771 (patch)
tree60ecda63c039299702d0c691b5614ef2d53e9c0c /package/unrar
parentba14e6c2aa8d060f59f1a8ecda0d60feb06f98d4 (diff)
unrar: new package
[Peter: also pass TARGET_LDFLAGS] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/unrar')
-rw-r--r--package/unrar/Config.in13
-rw-r--r--package/unrar/unrar.hash2
-rw-r--r--package/unrar/unrar.mk23
3 files changed, 38 insertions, 0 deletions
diff --git a/package/unrar/Config.in b/package/unrar/Config.in
new file mode 100644
index 000000000..29696c35a
--- /dev/null
+++ b/package/unrar/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_UNRAR
+ bool "unrar"
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ depends on BR2_USE_WCHAR
+ help
+ RAR file uncompressor.
+
+ http://www.rarlab.com/rar_add.htm
+
+comment "unrar needs a toolchain w/ C++, wchar, threads"
+ depends on !BR2_USE_WCHAR || !BR2_INSTALL_LIBSTDCPP \
+ || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/unrar/unrar.hash b/package/unrar/unrar.hash
new file mode 100644
index 000000000..4490d70f3
--- /dev/null
+++ b/package/unrar/unrar.hash
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256 ff593728aed0ac865908b8ea52cff449a4c298f095db2f3d27438ffbc3e35d5b unrarsrc-5.3.9.tar.gz
diff --git a/package/unrar/unrar.mk b/package/unrar/unrar.mk
new file mode 100644
index 000000000..89dff9bba
--- /dev/null
+++ b/package/unrar/unrar.mk
@@ -0,0 +1,23 @@
+################################################################################
+#
+# unrar
+#
+################################################################################
+
+UNRAR_VERSION = 5.3.9
+UNRAR_SOURCE = unrarsrc-$(UNRAR_VERSION).tar.gz
+UNRAR_SITE = http://www.rarlab.com/rar
+UNRAR_LICENSE = unrar
+UNRAR_LICENSE_FILES = license.txt
+
+define UNRAR_BUILD_CMDS
+ $(MAKE) CXX="$(TARGET_CXX)" STRIP="/bin/true" \
+ CXXFLAGS="$(TARGET_CXXFLAGS) -pthread" \
+ LDFLAGS="$(TARGET_LDFLAGS) -pthread" -C $(@D)
+endef
+
+define UNRAR_INSTALL_TARGET_CMDS
+ $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR)/usr install
+endef
+
+$(eval $(generic-package))