summaryrefslogtreecommitdiff
path: root/package/util-linux
diff options
context:
space:
mode:
authorMatt Weber <matthew.weber@rockwellcollins.com>2016-12-06 21:27:04 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-01-25 23:05:20 +1300
commit373b7efdb308fcb7607cbef63ee4d2644b46136f (patch)
tree1818b1e381d5fd2aa54893b759e311a319dd097d /package/util-linux
parentbe9157e1c060ef2ed1c358ee445e610e892c972b (diff)
util-linux: add selinux support
This patch adds optional libselinux support to the util-linux package, and also tweaks the PAM files instealled by util-linux to work properly in an SELinux context. Like was done for linux-pam, the tweak is done by having the SELinux related lines commented out in the original PAM file, and uncommented when SELinux support is enabled. Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Clayton Shotwell <clayton.shotwell@rockwellcollins.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Niranjan Reddy <niranjan.reddy@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Tested-by: Bryce Ferguson <bryce.ferguson@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/util-linux')
-rw-r--r--package/util-linux/su.pam2
-rw-r--r--package/util-linux/util-linux.mk14
2 files changed, 16 insertions, 0 deletions
diff --git a/package/util-linux/su.pam b/package/util-linux/su.pam
index f000c39db..84b18605c 100644
--- a/package/util-linux/su.pam
+++ b/package/util-linux/su.pam
@@ -7,7 +7,9 @@ account required pam_unix.so
password required pam_unix.so nullok
+# session required pam_selinux.so close
session required pam_limits.so
session required pam_env.so
session required pam_unix.so
session optional pam_lastlog.so
+# session required pam_selinux.so open
diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
index 53a6d9b78..84c4f0ec0 100644
--- a/package/util-linux/util-linux.mk
+++ b/package/util-linux/util-linux.mk
@@ -75,6 +75,19 @@ endif
UTIL_LINUX_CONF_ENV += LIBS="$(UTIL_LINUX_LIBS)"
UTIL_LINUX_MAKE_OPTS += LIBS="$(UTIL_LINUX_LIBS)"
+ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
+UTIL_LINUX_DEPENDENCIES += libselinux
+UTIL_LINUX_CONF_OPTS += --with-selinux
+define UTIL_LINUX_SELINUX_PAMFILES_TWEAK
+ $(foreach f,su su-l,
+ $(SED) 's/^# \(.*pam_selinux.so.*\)$$/\1/' \
+ $(TARGET_DIR)/etc/pam.d/$(f)
+ )
+endef
+else
+UTIL_LINUX_CONF_OPTS += --without-selinux
+endif
+
# Used by cramfs utils
UTIL_LINUX_DEPENDENCIES += $(if $(BR2_PACKAGE_ZLIB),zlib)
@@ -192,6 +205,7 @@ define UTIL_LINUX_INSTALL_PAMFILES
$(TARGET_DIR)/etc/pam.d/su
$(INSTALL) -m 0644 package/util-linux/su.pam \
$(TARGET_DIR)/etc/pam.d/su-l
+ $(UTIL_LINUX_SELINUX_PAMFILES_TWEAK)
endef
endif