summaryrefslogtreecommitdiff
path: root/package/util-linux
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2016-01-15 15:24:48 +0100
committerPeter Korsgaard <peter@korsgaard.com>2016-01-15 21:29:52 +0100
commit4c20ffc5effe4ae35f12e843eb72208a09c1471a (patch)
treed108bcac76b07ac3e3d94cea6afa5479860b6d03 /package/util-linux
parent07941f42777f83adeb5527cfb02b343458c39ede (diff)
util-linux: enable Python bindings for libmount
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/util-linux')
-rw-r--r--package/util-linux/util-linux.mk16
1 files changed, 14 insertions, 2 deletions
diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
index 58ace1d5b..f6e5d6292 100644
--- a/package/util-linux/util-linux.mk
+++ b/package/util-linux/util-linux.mk
@@ -23,8 +23,7 @@ UTIL_LINUX_CONF_ENV = scanf_cv_type_modifier=no \
$(if $(BR2_TOOLCHAIN_USES_UCLIBC),ac_cv_header_sys_timex_h=no)
UTIL_LINUX_CONF_OPTS += \
--disable-rpath \
- --disable-makeinstall-chown \
- --without-python
+ --disable-makeinstall-chown
# system depends on util-linux so we enable systemd support
# (which needs systemd to be installed)
@@ -136,6 +135,19 @@ ifeq ($(BR2_PACKAGE_UTIL_LINUX_BINARIES),)
UTIL_LINUX_CONF_OPTS += --disable-all-programs
endif
+# Install libmount Python bindings
+ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
+UTIL_LINUX_CONF_OPTS += --with-python
+UTIL_LINUX_DEPENDENCIES += $(if $(BR2_PACKAGE_PYTHON),python,python3)
+ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBMOUNT),y)
+UTIL_LINUX_CONF_OPTS += --enable-pylibmount
+else
+UTIL_LINUX_CONF_OPTS += --disable-pylibmount
+endif
+else
+UTIL_LINUX_CONF_OPTS += --without-python
+endif
+
# Install PAM configuration files
ifeq ($(BR2_PACKAGE_UTIL_LINUX_LOGIN_UTILS),y)
define UTIL_LINUX_INSTALL_PAMFILES