summaryrefslogtreecommitdiff
path: root/package/util-linux
diff options
context:
space:
mode:
authorRahul Bedarkar <rahul.bedarkar@imgtec.com>2016-09-15 15:57:02 +0530
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-09-16 18:42:33 +0200
commitc8252fdebb59424b2d4d65c9ea7ed2a6cd960e24 (patch)
tree131ea3a4de8df493b411be8cd053c590a9bea250 /package/util-linux
parent4f1a59924013928ff0ad3ed8cc2253a7f3485368 (diff)
util-linux: add optional dependency on readline
fdisk and sfdisk tools can be built with readline support. This patch adds optional dependency on readline if it is already selected. Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/util-linux')
-rw-r--r--package/util-linux/util-linux.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
index aa6f994a7..7b16ca40a 100644
--- a/package/util-linux/util-linux.mk
+++ b/package/util-linux/util-linux.mk
@@ -146,6 +146,13 @@ else
UTIL_LINUX_CONF_OPTS += --without-python
endif
+ifeq ($(BR2_PACKAGE_READLINE),y)
+UTIL_LINUX_CONF_OPTS += --with-readline
+UTIL_LINUX_DEPENDENCIES += readline
+else
+UTIL_LINUX_CONF_OPTS += --without-readline
+endif
+
# Install PAM configuration files
ifeq ($(BR2_PACKAGE_UTIL_LINUX_LOGIN_UTILS),y)
define UTIL_LINUX_INSTALL_PAMFILES