summaryrefslogtreecommitdiff
path: root/package/valgrind
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-21 22:27:03 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-11-06 23:54:16 +0100
commit56ea6a1391878c5e9e4b49efe147d7c9ee559200 (patch)
tree393e4fa219c1daaa1a7f7a568001be38877cca6a /package/valgrind
parent4fcba753836e43fceaf55fef2c1ac560c6e00210 (diff)
valgrind: use the BR2_ARM_CPU_ARM* options
Instead of using the exhaustive list of Cortex-A ARM cores, use BR2_ARM_CPU_ARMV7A instead. We also fix a wrong comment that said the Valgrind package could only be selected for Cortex-A8 and Cortex-A9, which was true a long time ago, but was no longer true since it was also enabled for all the other Cortex-A platforms. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/valgrind')
-rw-r--r--package/valgrind/Config.in7
-rw-r--r--package/valgrind/valgrind.mk4
2 files changed, 5 insertions, 6 deletions
diff --git a/package/valgrind/Config.in b/package/valgrind/Config.in
index 253555ba4..b7521b021 100644
--- a/package/valgrind/Config.in
+++ b/package/valgrind/Config.in
@@ -1,9 +1,8 @@
config BR2_PACKAGE_VALGRIND
bool "valgrind"
- depends on BR2_i386 || BR2_x86_64 || BR2_cortex_a5 || \
- BR2_cortex_a7 || BR2_cortex_a8 || BR2_cortex_a9 || \
- BR2_cortex_a12 || BR2_cortex_a15 || BR2_powerpc || \
- BR2_mips || BR2_mipsel || BR2_mips64 || BR2_mips64el
+ depends on BR2_i386 || BR2_x86_64 || BR2_ARM_CPU_ARMV7A || \
+ BR2_powerpc || BR2_mips || BR2_mipsel || BR2_mips64 || \
+ BR2_mips64el
help
Tool for debugging and profiling Linux programs.
diff --git a/package/valgrind/valgrind.mk b/package/valgrind/valgrind.mk
index 9b799410a..b65e0488f 100644
--- a/package/valgrind/valgrind.mk
+++ b/package/valgrind/valgrind.mk
@@ -16,8 +16,8 @@ VALGRIND_AUTORECONF = YES
# host tuple to determine whether it's being built for ARMv7 or
# not. Therefore, we adjust the host tuple to specify we're on
# ARMv7. The valgrind package is guaranteed, through Config.in, to
-# only be selected on Cortex A8 and Cortex A9 platforms.
-ifeq ($(BR2_cortex_a5)$(BR2_cortex_a7)$(BR2_cortex_a8)$(BR2_cortex_a9)$(BR2_cortex_a12)$(BR2_cortex_a15),y)
+# only be selected on ARMv7-A platforms.
+ifeq ($(BR2_ARM_CPU_ARMV7A),y)
VALGRIND_CONF_OPTS += \
--host=$(patsubst arm-%,armv7-%,$(GNU_TARGET_NAME))
endif