summaryrefslogtreecommitdiff
path: root/package/vim
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-21 07:32:59 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-21 12:27:39 +0100
commitab0f1bf29bd861f3a2274a7c6755e40ddba0830c (patch)
treefc29d8cc7a2f67eac7ba15c8799289ea510d75eb /package/vim
parentabde10199abc7160c083965961fdd82d9b0bd1a2 (diff)
package/vim: add optional support for gpm
When gpm was compiled before, vim will use it as optional dependency: $ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/vim | grep NEEDED | sort 0x0000000000000001 (NEEDED) Shared library: [libacl.so.1] 0x0000000000000001 (NEEDED) Shared library: [libc.so.1] 0x0000000000000001 (NEEDED) Shared library: [libdl.so.1] 0x0000000000000001 (NEEDED) Shared library: [libgpm.so.2] 0x0000000000000001 (NEEDED) Shared library: [libintl.so.8] 0x0000000000000001 (NEEDED) Shared library: [libm.so.1] 0x0000000000000001 (NEEDED) Shared library: [libncurses.so.5] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/vim')
-rw-r--r--package/vim/vim.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/vim/vim.mk b/package/vim/vim.mk
index a6b75d081..07493669d 100644
--- a/package/vim/vim.mk
+++ b/package/vim/vim.mk
@@ -27,6 +27,13 @@ VIM_CONF_OPTS = --with-tlib=ncurses --enable-gui=no --without-x
VIM_LICENSE = Charityware
VIM_LICENSE_FILES = README.txt
+ifeq ($(BR2_PACKAGE_GPM),y)
+VIM_CONF_OPTS += --enable-gpm
+VIM_DEPENDENCIES += gpm
+else
+VIM_CONF_OPTS += --disable-gpm
+endif
+
ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
VIM_CONF_OPTS += --enable-selinux
VIM_DEPENDENCIES += libselinux