summaryrefslogtreecommitdiff
path: root/package/vim
diff options
context:
space:
mode:
authorMatt Weber <matthew.weber@rockwellcollins.com>2015-06-02 08:28:31 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-01 10:19:11 +0200
commitcdc18ae10c0a026946a02a5cd6dad307baac285a (patch)
treefbba044d8eb3840b2928c43bd206d3439b49734f /package/vim
parentd39e0f4eb48de8fab5497e5b880732fbd7f79835 (diff)
vim: selinux support
Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/vim')
-rw-r--r--package/vim/vim.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/vim/vim.mk b/package/vim/vim.mk
index da84d14d8..518afafdc 100644
--- a/package/vim/vim.mk
+++ b/package/vim/vim.mk
@@ -28,6 +28,13 @@ VIM_CONF_OPTS = --with-tlib=ncurses --enable-gui=no --without-x
VIM_LICENSE = Charityware
VIM_LICENSE_FILES = README.txt
+ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
+VIM_CONF_OPTS += --enable-selinux
+VIM_DEPENDENCIES += libselinux
+else
+VIM_CONF_OPTS += --disable-selinux
+endif
+
define VIM_INSTALL_TARGET_CMDS
cd $(@D)/src; \
$(MAKE) DESTDIR=$(TARGET_DIR) installvimbin; \