summaryrefslogtreecommitdiff
path: root/package/weston
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2016-03-29 11:39:06 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-03-30 17:00:51 +0200
commit4582f907387edca62d7edf26472c8fe79649f4da (patch)
tree6c88ecad6ed68594a30fc0cb63cdc55a6444be40 /package/weston
parentdee8b591f54d8fced6242de488e2f7118e1aba75 (diff)
weston: handle dbus dependency
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/weston')
-rw-r--r--package/weston/weston.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/weston/weston.mk b/package/weston/weston.mk
index 363a2bf67..72190a8c5 100644
--- a/package/weston/weston.mk
+++ b/package/weston/weston.mk
@@ -26,6 +26,13 @@ WESTON_CONF_OPTS = \
WESTON_MAKE_OPTS = \
WAYLAND_PROTOCOLS_DATADIR=$(STAGING_DIR)/usr/share/wayland-protocols
+ifeq ($(BR2_PACKAGE_DBUS),y)
+WESTON_CONF_OPTS += --enable-dbus
+WESTON_DEPENDENCIES += dbus
+else
+WESTON_CONF_OPTS += --disable-dbus
+endif
+
# weston-launch must be u+s root in order to work properly
ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
define WESTON_PERMISSIONS