summaryrefslogtreecommitdiff
path: root/package/weston
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-02-21 23:36:24 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-02-22 12:14:18 +0100
commitaff0f97c5a568918744696d9164cfc52d6d1a221 (patch)
tree790061f3fb356dcd7a1b2ca8cfbf42dc164f0352 /package/weston
parentb5848e87f5ee90b2a758aaf5ce2392119581313d (diff)
package/weston: add support for the RDP compositor
Using the RDP compositor, one can run a headless machine to serve remote clients, using the RDP protocol. Add an option to enable the rdp-backend. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/weston')
-rw-r--r--package/weston/Config.in17
-rw-r--r--package/weston/weston.mk7
2 files changed, 24 insertions, 0 deletions
diff --git a/package/weston/Config.in b/package/weston/Config.in
index b7f4f27db..8983460e3 100644
--- a/package/weston/Config.in
+++ b/package/weston/Config.in
@@ -39,6 +39,23 @@ config BR2_PACKAGE_WESTON_HAS_COMPOSITOR
config BR2_PACKAGE_WESTON_FBDEV
bool "fbdev compositor"
+config BR2_PACKAGE_WESTON_RDP
+ bool "RDP compositor"
+ select BR2_PACKAGE_FREERDP
+ select BR2_PACKAGE_WESTON_HAS_COMPOSITOR
+ help
+ This enables the RDP backend, which allows accessing weston
+ through the network with any RDP-compliant client.
+
+ Please note that one must pass those options to weston for RDP
+ to be functional:
+ --rdp-tls-cert=/path/to/server.crt
+ --rdp-tls-key=/path/to/server.key
+
+ By default, Buildroot installs such files in /etc/freerdp/server/
+ so you may want to change them in a post-build script or a rootfs
+ overlay.
+
# rpi-userland is an EGL/GLES provider, so we can't select it
config BR2_PACKAGE_WESTON_RPI
bool "RPi compositor"
diff --git a/package/weston/weston.mk b/package/weston/weston.mk
index 8a5a891b7..bf49436fe 100644
--- a/package/weston/weston.mk
+++ b/package/weston/weston.mk
@@ -31,6 +31,13 @@ else
WESTON_CONF_OPTS += --disable-libunwind
endif
+ifeq ($(BR2_PACKAGE_WESTON_RDP),y)
+WESTON_DEPENDENCIES += freerdp
+WESTON_CONF_OPTS += --enable-rdp-compositor
+else
+WESTON_CONF_OPTS += --disable-rdp-compositor
+endif
+
ifeq ($(BR2_PACKAGE_WESTON_FBDEV),y)
WESTON_CONF_OPTS += --enable-fbdev-compositor
else