summaryrefslogtreecommitdiff
path: root/package/wget
diff options
context:
space:
mode:
authorRahul Bedarkar <rahul.bedarkar@imgtec.com>2016-11-09 00:06:41 +0530
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-11 22:11:57 +0100
commit2f257ec7d7334472effe756c6c789ea7da9ff215 (patch)
tree5dfe76249a0fd5843b4c7d6822903c5d43327d8a /package/wget
parentb1a2f09e6956f880c9f56d8be27e38adaca3179f (diff)
wget: fix ssl detection in static libs configuration
When building wget with openssl in static libs configuration, wget build system fails detect openssl because it doesn't specify LD flags for private libs used by openssl. This specifically happens when we pass --with-libssl-prefix to configure which tries to find ssl using custom flags. If we don't specify --with-libssl-prefix, it relies on pkg-config files to detect ssl and it's LD flags which helps with static linking. This commit removes --with-libssl-prefix conf opts. Since this case is similar to gnutls, we remove same conf opts for gnutls as well. wget can be built with either gnutls or openssl crypto libraries, so separate optional support for both is not required. This commit also does minor optimization by checking for either gnutls or openssl while at it. Fixes: http://autobuild.buildroot.net/results/c6a/c6abdff37b86471cf8b0ceffeff5472042923de0/ Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/wget')
-rw-r--r--package/wget/wget.mk19
1 files changed, 5 insertions, 14 deletions
diff --git a/package/wget/wget.mk b/package/wget/wget.mk
index 9cda76b6a..c9efc0330 100644
--- a/package/wget/wget.mk
+++ b/package/wget/wget.mk
@@ -17,26 +17,17 @@ WGET_DEPENDENCIES += busybox
endif
ifeq ($(BR2_PACKAGE_GNUTLS),y)
-WGET_CONF_OPTS += \
- --with-ssl=gnutls \
- --with-libgnutls-prefix=$(STAGING_DIR)
+WGET_CONF_OPTS += --with-ssl=gnutls
WGET_DEPENDENCIES += gnutls
-endif
-
-ifeq ($(BR2_PACKAGE_OPENSSL),y)
-WGET_CONF_OPTS += --with-ssl=openssl --with-libssl-prefix=$(STAGING_DIR)
+else ifeq ($(BR2_PACKAGE_OPENSSL),y)
+WGET_CONF_OPTS += --with-ssl=openssl
WGET_DEPENDENCIES += openssl
+else
+WGET_CONF_OPTS += --without-ssl
endif
ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
WGET_DEPENDENCIES += util-linux
endif
-# --with-ssl is default
-ifneq ($(BR2_PACKAGE_GNUTLS),y)
-ifneq ($(BR2_PACKAGE_OPENSSL),y)
-WGET_CONF_OPTS += --without-ssl
-endif
-endif
-
$(eval $(autotools-package))