summaryrefslogtreecommitdiff
path: root/package/wine
diff options
context:
space:
mode:
authorAndré Hentschel <nerv@dawncrow.de>2015-12-12 20:55:38 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-13 14:29:33 +0100
commit4037e4ec9498e05efef3936229c6522a6a02e81c (patch)
treebd297630935b79db1ca8d949e3514df506aa4289 /package/wine
parent4edc0f1cddf4948abb45e6c78a0a12b82bca8d14 (diff)
wine: Add OSMesa dependency
We have support for building the OSMesa lib since 81537f284f62c6586d50bd5cca78c2bf1375b88c Signed-off-by: André Hentschel <nerv@dawncrow.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/wine')
-rw-r--r--package/wine/wine.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/wine/wine.mk b/package/wine/wine.mk
index 38576dbeb..1a1fea045 100644
--- a/package/wine/wine.mk
+++ b/package/wine/wine.mk
@@ -27,7 +27,6 @@ WINE_CONF_OPTS = \
--without-hal \
--without-openal \
--without-opencl \
- --without-osmesa \
--without-oss
# Wine uses a wrapper around gcc, and uses the value of --host to
@@ -171,6 +170,13 @@ else
WINE_CONF_OPTS += --without-ldap
endif
+ifeq ($(BR2_PACKAGE_MESA3D_OSMESA),y)
+WINE_CONF_OPTS += --with-osmesa
+WINE_DEPENDENCIES += mesa3d
+else
+WINE_CONF_OPTS += --without-osmesa
+endif
+
ifeq ($(BR2_PACKAGE_SANE_BACKENDS),y)
WINE_CONF_OPTS += --with-sane
WINE_DEPENDENCIES += sane-backends