summaryrefslogtreecommitdiff
path: root/package/wine
diff options
context:
space:
mode:
authorAndré Hentschel <nerv@dawncrow.de>2015-12-14 00:57:05 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-15 22:57:10 +0100
commitb4b489ce36fa4e97a7a0994d7cea1265ff585439 (patch)
tree0a986d8c3d8b27452aa4266b669191e54a7c1e7b /package/wine
parentdd3afecc70c8b727af4a8d58e11ba2c67ff2ebd9 (diff)
wine: Add OpenAL dependency
Signed-off-by: André Hentschel <nerv@dawncrow.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/wine')
-rw-r--r--package/wine/wine.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/wine/wine.mk b/package/wine/wine.mk
index 1a1fea045..98958ef03 100644
--- a/package/wine/wine.mk
+++ b/package/wine/wine.mk
@@ -25,7 +25,6 @@ WINE_CONF_OPTS = \
--without-gphoto \
--without-gsm \
--without-hal \
- --without-openal \
--without-opencl \
--without-oss
@@ -163,6 +162,13 @@ else
WINE_CONF_OPTS += --without-curses
endif
+ifeq ($(BR2_PACKAGE_OPENAL),y)
+WINE_CONF_OPTS += --with-openal
+WINE_DEPENDENCIES += openal
+else
+WINE_CONF_OPTS += --without-openal
+endif
+
ifeq ($(BR2_PACKAGE_OPENLDAP),y)
WINE_CONF_OPTS += --with-ldap
WINE_DEPENDENCIES += openldap