summaryrefslogtreecommitdiff
path: root/package/wmctrl
diff options
context:
space:
mode:
authorJérôme Pouiller <jezz@sysmic.org>2014-01-02 22:29:40 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-01-03 22:38:33 +0100
commitac5473849c000d62ad3edee59c13f5451c4ac56f (patch)
treed8f1b1ea770407f0481d0e3b8eb7cba2ab903532 /package/wmctrl
parentfebd1123aa3baed15d3037486f7c54eaeddcf07f (diff)
wmctrl: new package
Provides command line access to almost all the features defined in the EWMH specification. It can be used, for example, to get information about the window manager, to get a detailed list of desktops and managed windows, to switch and resize desktops, to make windows full-screen, always-above or sticky, and to activate, close, move, resize, maximize and minimize them. [Thomas: - fixed license, which is GPLv2+, not GPLv2 - fixed wrapping of the Config.in help text - removed Config.in comment related to MMU dependency.] Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/wmctrl')
-rw-r--r--package/wmctrl/Config.in23
-rw-r--r--package/wmctrl/wmctrl.mk14
2 files changed, 37 insertions, 0 deletions
diff --git a/package/wmctrl/Config.in b/package/wmctrl/Config.in
new file mode 100644
index 000000000..334f47de7
--- /dev/null
+++ b/package/wmctrl/Config.in
@@ -0,0 +1,23 @@
+config BR2_PACKAGE_WMCTRL
+ bool "wmctrl"
+ select BR2_PACKAGE_XLIB_LIBX11
+ select BR2_PACKAGE_XLIB_LIBXMU
+ select BR2_PACKAGE_LIBGLIB2
+ depends on BR2_PACKAGE_XORG7
+ depends on BR2_USE_WCHAR # libglib2
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+ depends on BR2_USE_MMU # libglib2
+ help
+ Provides command line access to almost all the features
+ defined in the EWMH specification. It can be used, for
+ example, to get information about the window manager, to get
+ a detailed list of desktops and managed windows, to switch
+ and resize desktops, to make windows full-screen,
+ always-above or sticky, and to activate, close, move,
+ resize, maximize and minimize them.
+
+ http://tomas.styblo.name/wmctrl/
+
+comment "libglib2 needs a toolchain w/ wchar, threads"
+ depends on !BR2_USE_MMU
+ depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/wmctrl/wmctrl.mk b/package/wmctrl/wmctrl.mk
new file mode 100644
index 000000000..a4e0d8e31
--- /dev/null
+++ b/package/wmctrl/wmctrl.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# wmctrl
+#
+################################################################################
+
+WMCTRL_VERSION = 1.07
+WMCTRL_SITE = http://tomas.styblo.name/wmctrl/dist
+WMCTRL_LICENSE = GPLv2+
+WMCTRL_LICENSE_FILES = COPYING
+
+WMCTRL_DEPENDENCIES = libglib2 xlib_libX11 xlib_libXmu
+
+$(eval $(autotools-package))