summaryrefslogtreecommitdiff
path: root/package/wpa_supplicant
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2014-12-31 23:50:54 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-01 11:31:14 +0100
commitb7e7b417fa1210a7f9c4e76ee747238981dcd012 (patch)
treece41636c07b4c4d397f232c4477f46b4113ffafa /package/wpa_supplicant
parent10f42fa8ae8d05bf36fd5e65f0ab2a1315cab18d (diff)
wpa_supplicant: fix indentation and change file permissions
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/wpa_supplicant')
-rw-r--r--package/wpa_supplicant/wpa_supplicant.mk26
1 files changed, 13 insertions, 13 deletions
diff --git a/package/wpa_supplicant/wpa_supplicant.mk b/package/wpa_supplicant/wpa_supplicant.mk
index 10b2c0aa5..682cb4c1f 100644
--- a/package/wpa_supplicant/wpa_supplicant.mk
+++ b/package/wpa_supplicant/wpa_supplicant.mk
@@ -82,18 +82,18 @@ ifeq ($(BR2_PACKAGE_DBUS),y)
ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_DBUS_OLD),y)
WPA_SUPPLICANT_CONFIG_ENABLE += CONFIG_CTRL_IFACE_DBUS=
define WPA_SUPPLICANT_INSTALL_DBUS_OLD
- $(INSTALL) -D \
- $(@D)/wpa_supplicant/dbus/$(WPA_SUPPLICANT_DBUS_OLD_SERVICE).service \
- $(TARGET_DIR)/usr/share/dbus-1/system-services/$(WPA_SUPPLICANT_DBUS_OLD_SERVICE).service
+ $(INSTALL) -m 0644 -D \
+ $(@D)/wpa_supplicant/dbus/$(WPA_SUPPLICANT_DBUS_OLD_SERVICE).service \
+ $(TARGET_DIR)/usr/share/dbus-1/system-services/$(WPA_SUPPLICANT_DBUS_OLD_SERVICE).service
endef
endif
ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_DBUS_NEW),y)
WPA_SUPPLICANT_CONFIG_ENABLE += CONFIG_CTRL_IFACE_DBUS_NEW
define WPA_SUPPLICANT_INSTALL_DBUS_NEW
- $(INSTALL) -D \
- $(@D)/wpa_supplicant/dbus/$(WPA_SUPPLICANT_DBUS_NEW_SERVICE).service \
- $(TARGET_DIR)/usr/share/dbus-1/system-services/$(WPA_SUPPLICANT_DBUS_NEW_SERVICE).service
+ $(INSTALL) -m 0644 -D \
+ $(@D)/wpa_supplicant/dbus/$(WPA_SUPPLICANT_DBUS_NEW_SERVICE).service \
+ $(TARGET_DIR)/usr/share/dbus-1/system-services/$(WPA_SUPPLICANT_DBUS_NEW_SERVICE).service
endef
endif
@@ -115,10 +115,10 @@ endif
define WPA_SUPPLICANT_CONFIGURE_CMDS
cp $(@D)/wpa_supplicant/defconfig $(WPA_SUPPLICANT_CONFIG)
sed -i $(patsubst %,-e 's/^#\(%\)/\1/',$(WPA_SUPPLICANT_CONFIG_ENABLE)) \
- $(patsubst %,-e 's/^\(%\)/#\1/',$(WPA_SUPPLICANT_CONFIG_DISABLE)) \
- $(patsubst %,-e '1i%=y',$(WPA_SUPPLICANT_CONFIG_SET)) \
- $(patsubst %,-e %,$(WPA_SUPPLICANT_CONFIG_EDITS)) \
- $(WPA_SUPPLICANT_CONFIG)
+ $(patsubst %,-e 's/^\(%\)/#\1/',$(WPA_SUPPLICANT_CONFIG_DISABLE)) \
+ $(patsubst %,-e '1i%=y',$(WPA_SUPPLICANT_CONFIG_SET)) \
+ $(patsubst %,-e %,$(WPA_SUPPLICANT_CONFIG_EDITS)) \
+ $(WPA_SUPPLICANT_CONFIG)
endef
# LIBS for wpa_supplicant, LIBS_c for wpa_cli, LIBS_p for wpa_passphrase
@@ -146,9 +146,9 @@ endif
ifeq ($(BR2_PACKAGE_DBUS),y)
define WPA_SUPPLICANT_INSTALL_DBUS
- $(INSTALL) -D \
- $(@D)/wpa_supplicant/dbus/dbus-wpa_supplicant.conf \
- $(TARGET_DIR)/etc/dbus-1/system.d/wpa_supplicant.conf
+ $(INSTALL) -m 0644 -D \
+ $(@D)/wpa_supplicant/dbus/dbus-wpa_supplicant.conf \
+ $(TARGET_DIR)/etc/dbus-1/system.d/wpa_supplicant.conf
$(WPA_SUPPLICANT_INSTALL_DBUS_OLD)
$(WPA_SUPPLICANT_INSTALL_DBUS_NEW)
endef