summaryrefslogtreecommitdiff
path: root/package/xdotool
diff options
context:
space:
mode:
authorErico Nunes <nunes.erico@gmail.com>2015-12-28 23:59:27 -0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-29 16:00:45 +0100
commitfeca4c8c5a5a934ecc69d46426980e32664e477c (patch)
tree378b86334cdd334be39ac6cabed5a791598f8a11 /package/xdotool
parentec581782f0b523738a569d8d263629158cfcb28e (diff)
xdotool: new package
xdotool is a command-line X11 automation tool. http://www.semicomplete.com/projects/xdotool [Thomas: - fix <pkg>_LICENSE, as noticed by Baruch - use $(TARGET_MAKE_ENV).] Signed-off-by: Erico Nunes <nunes.erico@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/xdotool')
-rw-r--r--package/xdotool/Config.in11
-rw-r--r--package/xdotool/xdotool.hash2
-rw-r--r--package/xdotool/xdotool.mk24
3 files changed, 37 insertions, 0 deletions
diff --git a/package/xdotool/Config.in b/package/xdotool/Config.in
new file mode 100644
index 000000000..4d5f590aa
--- /dev/null
+++ b/package/xdotool/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_XDOTOOL
+ bool "xdotool"
+ depends on BR2_PACKAGE_XORG7
+ select BR2_PACKAGE_XLIB_LIBXTST
+ select BR2_PACKAGE_XLIB_LIBXINERAMA
+ select BR2_PACKAGE_LIBXKBCOMMON
+ select BR2_PACKAGE_XLIB_LIBX11
+ help
+ Command-line X11 automation tool
+
+ http://www.semicomplete.com/projects/xdotool
diff --git a/package/xdotool/xdotool.hash b/package/xdotool/xdotool.hash
new file mode 100644
index 000000000..f8adcd595
--- /dev/null
+++ b/package/xdotool/xdotool.hash
@@ -0,0 +1,2 @@
+# locally computed hash
+sha256 b097ef0e3897d1a24e3f45f0faed58329742d3d9434b9b46eb97eb1040f999bf xdotool-v3.20150503.1.tar.gz
diff --git a/package/xdotool/xdotool.mk b/package/xdotool/xdotool.mk
new file mode 100644
index 000000000..a799ea470
--- /dev/null
+++ b/package/xdotool/xdotool.mk
@@ -0,0 +1,24 @@
+################################################################################
+#
+# xdotool
+#
+################################################################################
+
+XDOTOOL_VERSION = v3.20150503.1
+XDOTOOL_SITE = $(call github,jordansissel,xdotool,$(XDOTOOL_VERSION))
+XDOTOOL_LICENSE = BSD-3c
+XDOTOOL_LICENSE_FILES = COPYRIGHT
+XDOTOOL_DEPENDENCIES = xlib_libXtst xlib_libXinerama libxkbcommon xlib_libX11
+
+define XDOTOOL_BUILD_CMDS
+ $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+endef
+
+# Avoid 'install' target to skip 'post-install' which runs ldconfig on host
+define XDOTOOL_INSTALL_TARGET_CMDS
+ $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+ pre-install installlib installprog installheader \
+ PREFIX="$(TARGET_DIR)/usr"
+endef
+
+$(eval $(generic-package))