summaryrefslogtreecommitdiff
path: root/package/xorriso
diff options
context:
space:
mode:
authorSteve Kenton <skenton@ou.edu>2015-01-10 13:37:43 -0600
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-14 22:38:34 +0100
commit08c85a573ecd69267b3b02e19f5e1172edbe0455 (patch)
treedc96ae81cbb5702fba6f75becfa15c0cd67122c2 /package/xorriso
parent469b7765d210cf5f36582811c8f7b8189735a32e (diff)
xorriso: new package
xorriso cd/dvd/bd iso 9660 manipulation and disc burner. libburnia is a project for reading, mastering and writing optical discs. Currently it is comprised of libraries named libisofs, libburn, libisoburn, a cdrecord emulator named cdrskin, and an integrated multi-session tool named xorriso. The software runs on GNU/Linux, FreeBSD, Solaris, NetBSD. It is base of the GNU xorriso package and is actively maintained. [Thomas: - Rewrap Config.in help text - Add optional dependencies on libcdio, readline, acl, attr, zlib, bzip2. - Handle thread support. - Add hash file.] Signed-off-by Stephen M. Kenton <skenton@ou.edu> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/xorriso')
-rw-r--r--package/xorriso/Config.in21
-rw-r--r--package/xorriso/xorriso.hash2
-rw-r--r--package/xorriso/xorriso.mk66
3 files changed, 89 insertions, 0 deletions
diff --git a/package/xorriso/Config.in b/package/xorriso/Config.in
new file mode 100644
index 000000000..cd60d7fbd
--- /dev/null
+++ b/package/xorriso/Config.in
@@ -0,0 +1,21 @@
+config BR2_PACKAGE_XORRISO
+ bool "xorriso"
+ select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
+ depends on BR2_USE_WCHAR
+ depends on BR2_LARGEFILE
+ help
+ xorriso cd/dvd/bd iso 9660 manipulation and disc burner.
+
+ libburnia is a project for reading, mastering and writing
+ optical discs. Currently it is comprised of libraries named
+ libisofs, libburn, libisoburn, a cdrecord emulator named
+ cdrskin, and an integrated multi-session tool named xorriso.
+ The software runs on GNU/Linux, FreeBSD, Solaris, NetBSD.
+ It is base of the GNU xorriso package and is actively
+ maintained.
+
+ http://libburnia-project.org/
+ http://www.gnu.org/software/xorriso
+
+comment "xorriso needs a toolchain w/ wchar, largefile"
+ depends on !BR2_USE_WCHAR || !BR2_LARGEFILE
diff --git a/package/xorriso/xorriso.hash b/package/xorriso/xorriso.hash
new file mode 100644
index 000000000..98a716d5e
--- /dev/null
+++ b/package/xorriso/xorriso.hash
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 901204634651533f7cbd105eab560534702458258529aac4b2f0fc946992107e xorriso-1.3.8.tar.gz
diff --git a/package/xorriso/xorriso.mk b/package/xorriso/xorriso.mk
new file mode 100644
index 000000000..3c068f715
--- /dev/null
+++ b/package/xorriso/xorriso.mk
@@ -0,0 +1,66 @@
+###############################################################################
+#
+# xorriso
+#
+###############################################################################
+
+XORRISO_VERSION = 1.3.8
+XORRISO_SITE = $(BR2_GNU_MIRROR)/xorriso
+XORRISO_LICENSE = GPLv3+
+XORRISO_LICENSE_FILES = COPYING COPYRIGHT
+
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+XORRISO_DEPENDENCIES += libiconv
+endif
+
+ifeq ($(BR2_PACKAGE_LIBCDIO),y)
+XORRISO_DEPENDENCIES += host-pkgconf libcdio
+XORRISO_CONF_OPTS += \
+ --enable-pkg-check-modules \
+ --enable-libcdio
+else
+XORRISO_CONF_OPTS += --disable-libcdio
+endif
+
+ifeq ($(BR2_PACKAGE_READLINE),y)
+XORRISO_DEPENDENCIES += readline
+XORRISO_CONF_OPTS += --enable-libreadline
+else
+XORRISO_CONF_OPTS += --disable-libreadline
+endif
+
+ifeq ($(BR2_PACKAGE_ACL),y)
+XORRISO_DEPENDENCIES += acl
+XORRISO_CONF_OPTS += --enable-libacl
+else
+XORRISO_CONF_OPTS += --disable-libacl
+endif
+
+ifeq ($(BR2_PACKAGE_ATTR),y)
+XORRISO_DEPENDENCIES += attr
+XORRISO_CONF_OPTS += --enable-xattr
+else
+XORRISO_CONF_OPTS += --disable-xattr
+endif
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+XORRISO_DEPENDENCIES += zlib
+XORRISO_CONF_OPTS += --enable-zlib
+else
+XORRISO_CONF_OPTS += --disable-zlib
+endif
+
+ifeq ($(BR2_PACKAGE_BZIP2),y)
+XORRISO_DEPENDENCIES += bzip2
+XORRISO_CONF_OPTS += --enable-libbz2
+else
+XORRISO_CONF_OPTS += --disable-libbz2
+endif
+
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+XORRISO_CONF_OPTS += --enable-jtethreads
+else
+XORRISO_CONF_OPTS += --disable-jtethreads
+endif
+
+$(eval $(autotools-package))