summaryrefslogtreecommitdiff
path: root/package/xorriso
diff options
context:
space:
mode:
authorBenoît Allard <benoit.allard@greenbone.net>2016-03-16 14:55:15 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-03-30 21:09:05 +0200
commit2b5120ca92c96d9c4a08019ea5382aa7d14d96d0 (patch)
treef18964d7062224edc8db3bd6e7511753ba676529 /package/xorriso
parente766f61cc046b522b38d2596783d06349f11d05e (diff)
xorriso: Add host variant
Signed-off-by: Benoît Allard <benoit.allard@greenbone.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/xorriso')
-rw-r--r--package/xorriso/Config.in.host14
-rw-r--r--package/xorriso/xorriso.mk11
2 files changed, 25 insertions, 0 deletions
diff --git a/package/xorriso/Config.in.host b/package/xorriso/Config.in.host
new file mode 100644
index 000000000..2baa04374
--- /dev/null
+++ b/package/xorriso/Config.in.host
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_HOST_XORRISO
+ bool "host xorriso"
+ help
+ xorriso copies file objects from POSIX compliant
+ filesystems into Rock Ridge enhanced ISO 9660 filesystems
+ and allows session-wise manipulation of such filesystems.
+ It can load the management information of existing ISO
+ images and it writes the session results to optical media
+ or to filesystem objects.
+
+ Vice versa xorriso is able to copy file objects out of ISO
+ 9660 filesystems.
+
+ https://www.gnu.org/software/xorriso
diff --git a/package/xorriso/xorriso.mk b/package/xorriso/xorriso.mk
index e8bb5cbab..57537e897 100644
--- a/package/xorriso/xorriso.mk
+++ b/package/xorriso/xorriso.mk
@@ -8,6 +8,16 @@ XORRISO_VERSION = 1.4.2
XORRISO_SITE = $(BR2_GNU_MIRROR)/xorriso
XORRISO_LICENSE = GPLv3+
XORRISO_LICENSE_FILES = COPYING COPYRIGHT
+HOST_XORRISO_DEPENDENCIES =
+# Disable everything until we actually need those feature, and add the correct
+# host-libraries
+HOST_XORRISO_CONF_OPTS = \
+ --disable-zlib \
+ --disable-bzip2 \
+ --disable-libcdio \
+ --disable-libreadline \
+ --disable-libedit \
+ --disable-libacl
ifeq ($(BR2_PACKAGE_LIBICONV),y)
XORRISO_DEPENDENCIES += libiconv
@@ -64,3 +74,4 @@ XORRISO_CONF_OPTS += --disable-jtethreads
endif
$(eval $(autotools-package))
+$(eval $(host-autotools-package))