summaryrefslogtreecommitdiff
path: root/package/yad
diff options
context:
space:
mode:
authorJames Knight <james.knight@rockwellcollins.com>2015-10-30 11:39:27 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-11-04 17:05:43 +0100
commit701200973863f7b74b823fed53067c57adb81876 (patch)
tree5f503321749b39d93ce6fe94069272c5c69e4d32 /package/yad
parent1072b38788b03f39bb5f302a5b71837f25af2d9f (diff)
yad: new package
[Thomas: remove dependency on libglib2, as it is not tested directly by yad's configure script, and is anyway guaranteed to be available since yad depends on gtk2 or gtk3, which both require libglib2.] Signed-off-by: James Knight <james.knight@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/yad')
-rw-r--r--package/yad/Config.in13
-rw-r--r--package/yad/yad.hash2
-rw-r--r--package/yad/yad.mk24
3 files changed, 39 insertions, 0 deletions
diff --git a/package/yad/Config.in b/package/yad/Config.in
new file mode 100644
index 000000000..e4b63a248
--- /dev/null
+++ b/package/yad/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_YAD
+ bool "yad"
+ depends on BR2_PACKAGE_XORG7
+ depends on BR2_PACKAGE_LIBGTK2 || BR2_PACKAGE_LIBGTK3
+ help
+ YAD (yet another dialog) is a tool for create graphical dialogs
+ from shell scripts.
+
+ http://sourceforge.net/projects/yad-dialog/
+
+comment "yad needs libgtk2 or libgtk3"
+ depends on BR2_PACKAGE_XORG7
+ depends on !BR2_PACKAGE_LIBGTK2 && !BR2_PACKAGE_LIBGTK3
diff --git a/package/yad/yad.hash b/package/yad/yad.hash
new file mode 100644
index 000000000..4e88ab014
--- /dev/null
+++ b/package/yad/yad.hash
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 c91d6a9eb36abdb502d2d8ada0ec29c266b94a6628f723adeca436bee0b6c55c yad-0.31.2.tar.xz
diff --git a/package/yad/yad.mk b/package/yad/yad.mk
new file mode 100644
index 000000000..9d7ab370c
--- /dev/null
+++ b/package/yad/yad.mk
@@ -0,0 +1,24 @@
+################################################################################
+#
+# yad
+#
+################################################################################
+
+YAD_VERSION = 0.31.2
+YAD_SOURCE = yad-$(YAD_VERSION).tar.xz
+YAD_SITE = http://sourceforge.net/projects/yad-dialog/files
+YAD_LICENSE = GPLv3
+YAD_LICENSE_FILES = COPYING
+YAD_DEPENDENCIES = host-intltool host-pkgconf
+
+YAD_CONF_OPTS = --enable-html=no
+
+ifeq ($(BR2_PACKAGE_LIBGTK3),y)
+YAD_DEPENDENCIES += libgtk3
+YAD_CONF_OPTS += --with-gtk=gtk3
+else
+YAD_DEPENDENCIES += libgtk2
+YAD_CONF_OPTS += --with-gtk=gtk2
+endif
+
+$(eval $(autotools-package))