summaryrefslogtreecommitdiff
path: root/package/yaml-cpp
diff options
context:
space:
mode:
authorJörg Krause <joerg.krause@embedded.rocks>2015-07-30 20:39:46 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-30 23:08:23 +0200
commit3d15325a925b03ee223578483eb80d20b95ae4ce (patch)
treef72d04cce95a5800dc79b66e4054e70fc2726783 /package/yaml-cpp
parent75369a86106c1beae70f78519b8f9436f1a7e821 (diff)
package/yaml-cpp: disable testing and parse tools
The gmock testing framework uses fork() and therefor yaml-cpp fails to build for a MMU-less targets. Since we are only interested in building the yaml-cpp library we disable the testing and parse tools (command line tools). Fixes: http://autobuild.buildroot.net/results/2ce/2ce3c6d0140696cdf73f2ad1499b779c83ad8f6e/ Cc: Sebastien Bourdelin <sebastien.bourdelin@savoirfairelinux.com> Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/yaml-cpp')
-rw-r--r--package/yaml-cpp/yaml-cpp.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/yaml-cpp/yaml-cpp.mk b/package/yaml-cpp/yaml-cpp.mk
index cea54a946..6a01b02a3 100644
--- a/package/yaml-cpp/yaml-cpp.mk
+++ b/package/yaml-cpp/yaml-cpp.mk
@@ -12,4 +12,7 @@ YAML_CPP_LICENSE_FILES = license.txt
YAML_CPP_DEPENDENCIES = boost
+# Disable testing and parse tools
+YAML_CPP_CONF_OPTS += -DYAML_CPP_BUILD_TOOLS=OFF
+
$(eval $(cmake-package))