summaryrefslogtreecommitdiff
path: root/package/zsh
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-21 10:50:12 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-21 12:42:47 +0100
commitc7bfa231072412531c6c31c5f76fbd294ef55910 (patch)
tree86e4c1b49ca9c72a3f7c25ba016935737922fcf2 /package/zsh
parent3fc55da0e8479fc6103af80c3a08334fbaacc5cc (diff)
package/zsh: add optional support for pcre
When pcre was compiled before, zsh will use it as optional dependency: $ output/host/usr/bin/x86_64-linux-readelf -a output/target/bin/zsh | grep NEEDED 0x0000000000000001 (NEEDED) Shared library: [libgdbm.so.4] 0x0000000000000001 (NEEDED) Shared library: [libpcre.so.1] [...] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/zsh')
-rw-r--r--package/zsh/zsh.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/zsh/zsh.mk b/package/zsh/zsh.mk
index 9f4a5827b..8659fc401 100644
--- a/package/zsh/zsh.mk
+++ b/package/zsh/zsh.mk
@@ -26,6 +26,13 @@ else
ZSH_CONF_OPTS += --disable-cap
endif
+ifeq ($(BR2_PACKAGE_PCRE),y)
+ZSH_CONF_OPTS += --enable-pcre
+ZSH_DEPENDENCIES += pcre
+else
+ZSH_CONF_OPTS += --disable-pcre
+endif
+
# Remove versioned zsh-x.y.z binary taking up space
define ZSH_TARGET_INSTALL_FIXUPS
rm -f $(TARGET_DIR)/bin/zsh-$(ZSH_VERSION)