summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorJens Kleintje <jkleintje@ultratronik.de>2017-02-11 12:05:30 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-02-11 15:19:48 +0100
commit056b5572fc20b4d3a98dbe12e4ec77f2fa360090 (patch)
tree726b4d8f662117077a0b59fa36c173f2eb9927a7 /package
parent49a33d3a229571e22ab783cbb1e5cace06ad7b99 (diff)
poppler: Add option for Qt5 support
Add an option to build the libpoppler-qt5 library. Signed-off-by: Andreas Naumann <anaumann@ultratronik.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/poppler/Config.in9
-rw-r--r--package/poppler/poppler.mk7
2 files changed, 16 insertions, 0 deletions
diff --git a/package/poppler/Config.in b/package/poppler/Config.in
index 2ca3ff62b..d741f6528 100644
--- a/package/poppler/Config.in
+++ b/package/poppler/Config.in
@@ -24,6 +24,15 @@ config BR2_PACKAGE_POPPLER_QT
comment "poppler Qt support needs a toolchain not affected by Binutils bug 19405"
depends on BR2_TOOLCHAIN_HAS_BINUTILS_BUG_19405
+config BR2_PACKAGE_POPPLER_QT5
+ bool "Qt5 support"
+ depends on BR2_PACKAGE_QT5
+ select BR2_PACKAGE_QT5BASE_GUI
+ select BR2_PACKAGE_QT5BASE_WIDGETS
+ select BR2_PACKAGE_QT5BASE_XML
+ help
+ Build Qt support into the Poppler library
+
endif
comment "poppler needs a toolchain w/ C++, threads"
diff --git a/package/poppler/poppler.mk b/package/poppler/poppler.mk
index 3e8a9f4c3..022c2c5e9 100644
--- a/package/poppler/poppler.mk
+++ b/package/poppler/poppler.mk
@@ -87,6 +87,13 @@ else
POPPLER_CONF_OPTS += --disable-poppler-qt4
endif
+ifeq ($(BR2_PACKAGE_POPPLER_QT5),y)
+POPPLER_DEPENDENCIES += qt5base
+POPPLER_CONF_OPTS += --enable-poppler-qt5
+else
+POPPLER_CONF_OPTS += --disable-poppler-qt5
+endif
+
ifeq ($(BR2_PACKAGE_OPENJPEG),y)
POPPLER_DEPENDENCIES += openjpeg
POPPLER_CONF_OPTS += --enable-libopenjpeg