summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2017-02-12 22:15:39 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-02-15 22:11:11 +0100
commitf165032e4f01aa46b43cc8136bac1c5b47aa8545 (patch)
treed65765401ba090c900d52f7cd70770a4b3e2243f /package
parentdc7fcbe494ffddcaba630889fe1a2915569be3f1 (diff)
package: add generic support for lz archives
This commit teaches the generic package handling code how to extract .tar.lz archives. When lzip is not installed on the host, host-lzip gets built automatically. Signed-off-by: Baruch Siach <baruch@tkos.co.il> Reviewed-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/pkg-utils.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
index 38d00dbbf..c95e77953 100644
--- a/package/pkg-utils.mk
+++ b/package/pkg-utils.mk
@@ -36,6 +36,7 @@ pkgname = $(lastword $(subst /, ,$(pkgdir)))
# Define extractors for different archive suffixes
INFLATE.bz2 = $(BZCAT)
INFLATE.gz = $(ZCAT)
+INFLATE.lz = $(LZCAT)
INFLATE.lzma = $(XZCAT)
INFLATE.tbz = $(BZCAT)
INFLATE.tbz2 = $(BZCAT)