summaryrefslogtreecommitdiff
path: root/support/scripts
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2016-06-30 09:25:04 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-01 00:03:54 +0200
commit8a64ade2f3dc5ccce53c50db2112d9a8fae94024 (patch)
tree59a34b570ece80ed0f38141ece980e1e4d1b9d08 /support/scripts
parent7835a8356504dbd765aed7fca02d9da881ef1e6e (diff)
scanpypi: rework runtime dependency handling
In most cases Python's package dependencies found in setup.py are runtime dependencies and hence don't need to be mentioned in *.mk file. Also add '# runtime' tag to select statements in Config.in. __create_mk_requirements() itself is left for future uses (cffi backend handling etc.). Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'support/scripts')
-rwxr-xr-xsupport/scripts/scanpypi4
1 files changed, 1 insertions, 3 deletions
diff --git a/support/scripts/scanpypi b/support/scripts/scanpypi
index 230791f15..79a888c5b 100755
--- a/support/scripts/scanpypi
+++ b/support/scripts/scanpypi
@@ -466,8 +466,6 @@ class BuildrootPackage():
lines += self.__create_mk_download_info()
lines += self.__create_mk_setup()
lines += self.__create_mk_license()
- if self.pkg_req:
- lines += self.__create_mk_requirements()
lines.append('\n')
lines.append('$(eval $(python-package))')
@@ -518,7 +516,7 @@ class BuildrootPackage():
lines.append(bool_line)
if self.pkg_req:
for dep in self.pkg_req:
- dep_line = '\tselect BR2_PACKAGE_{req}\n'.format(
+ dep_line = '\tselect BR2_PACKAGE_{req} # runtime\n'.format(
req=dep.upper().replace('-', '_'))
lines.append(dep_line)