summaryrefslogtreecommitdiff
path: root/support
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-10-19 21:53:02 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-10-19 23:19:14 +0200
commit5feff4403833a4aa7cddb99c5da6083c090cd15f (patch)
tree183e649f4d5e5d321bd6c52d7763245cc4c2678f /support
parent092d3e5e0c28f131e1a6bf375273f4d8f7c2f16d (diff)
core/br2-external: export paths and descriptions
Now that we support multiple br2-external trees, BR2_EXTERNAL is no longer exported in the environment. This means that post-build scripts in a br2-external tree can no longer find their own files (well, they could re-invent the path by stripping their known-relative path, but that'd be ugly, especially since we can very well provide it). Export the path for each br2-external trees as environment variables. Do so for the description as well, as a courtesy. Also, re-order variable definitions to be more logical: first, purely internal variables, then exported variables. Reported-by: Benoît Allard <benoit.allard@greenbone.net> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Benoît Allard <benoit.allard@greenbone.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'support')
-rwxr-xr-xsupport/scripts/br2-external4
1 files changed, 2 insertions, 2 deletions
diff --git a/support/scripts/br2-external b/support/scripts/br2-external
index 038525e01..848c851ba 100755
--- a/support/scripts/br2-external
+++ b/support/scripts/br2-external
@@ -142,10 +142,10 @@ do_mk() {
br2_ext="${BR2_EXT_PATHS["${br2_name}"]}"
printf '\n'
printf 'BR2_EXTERNAL_NAMES += %s\n' "${br2_name}"
- printf 'BR2_EXTERNAL_%s_PATH = %s\n' "${br2_name}" "${br2_ext}"
- printf 'BR2_EXTERNAL_%s_DESC = %s\n' "${br2_name}" "${br2_desc}"
printf 'BR2_EXTERNAL_DIRS += %s\n' "${br2_ext}"
printf 'BR2_EXTERNAL_MKS += %s/external.mk\n' "${br2_ext}"
+ printf 'export BR2_EXTERNAL_%s_PATH = %s\n' "${br2_name}" "${br2_ext}"
+ printf 'export BR2_EXTERNAL_%s_DESC = %s\n' "${br2_name}" "${br2_desc}"
done
}