summaryrefslogtreecommitdiff
path: root/toolchain/helpers.mk
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@gmail.com>2016-04-27 22:15:03 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-04-27 22:19:19 +0200
commit4b201090d8a9705c1660101d5ee3078a88ded9ee (patch)
treea2051a200ee4adeada2c0d87da073ba9da249110 /toolchain/helpers.mk
parent6bb03553005c1773a0a5b18d4c5a4f3be3e50add (diff)
toolchain/helper: update check_unusable_toolchain comment
Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/helpers.mk')
-rw-r--r--toolchain/helpers.mk9
1 files changed, 6 insertions, 3 deletions
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 4548eded3..d28a2caed 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -348,9 +348,12 @@ check_cross_compiler_exists = \
fi
#
-# Check for toolchains known not to work with Buildroot. For now, we
-# only check for Angstrom toolchains, by looking at the vendor part of
-# the host tuple.
+# Check for toolchains known not to work with Buildroot.
+# - For the Angstrom toolchains, we check by looking at the vendor part of
+# the host tuple.
+# - Exclude distro-class toolchains which are not relocatable.
+# - Exclude broken toolchains which return "libc.a" with -print-file-name.
+# - Exclude toolchains which doesn't support --sysroot option.
#
# $1: cross-gcc path
#