summaryrefslogtreecommitdiff
path: root/toolchain/helpers.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-10-08 20:17:09 +0200
committerPeter Korsgaard <peter@korsgaard.com>2013-10-09 16:01:25 +0200
commita1d94aaa3a2191121b28cf19ba8472f2e8f87d01 (patch)
treebfc86978e17d63a9d15612e338a0609495b92d3a /toolchain/helpers.mk
parent8e05ebca22c63b2bd1c0b09a8ead2a8250c105f5 (diff)
toolchain-external: add support for musl C library
This commit adds support for external toolchains based on the musl C library, as available from http://www.musl-libc.org. Note that the pre-built musl toolchains available from http://musl.codu.org/ are not working for the moment, since they lack sysroot support. However, this problem has been reported to the maintainer, who has already added sysroot support in his scripts at https://bitbucket.org/GregorR/musl-cross, and therefore the next version of the pre-built toolchains should work with Buildroot out-of-the-box. In the mean time, the musl-cross script must be used to build the toolchain. [Peter: reword comment] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'toolchain/helpers.mk')
-rw-r--r--toolchain/helpers.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index a4a13c732..b6fe04c41 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -209,6 +209,17 @@ check_glibc = \
$(call check_glibc_rpc_feature,$${SYSROOT_DIR})
#
+# Check that the selected C library really is musl
+#
+# $1: sysroot directory
+check_musl = \
+ SYSROOT_DIR="$(strip $1)"; \
+ if test ! -f $${SYSROOT_DIR}/lib/libc.so -o -e $${SYSROOT_DIR}/lib/libm.so ; then \
+ echo "Incorrect selection of the C library" ; \
+ exit -1; \
+ fi
+
+#
# Check the conformity of Buildroot configuration with regard to the
# uClibc configuration of the external toolchain, for a particular
# feature.