summaryrefslogtreecommitdiff
path: root/toolchain/toolchain-buildroot
diff options
context:
space:
mode:
authorFabio Porcedda <fabio.porcedda@gmail.com>2014-02-14 10:55:04 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-14 21:08:35 +0100
commitb2fd9f90e23e25ab6c55f116c2cf3c244d122ec2 (patch)
treec1f67ca23f1efe0a696751a5145e65ad7ea603cd /toolchain/toolchain-buildroot
parent6f13130ac9a1a5eebfccbd8c9f04a6ec3f5ceba2 (diff)
package: add toolchain dependency to every target package
This commit makes the dependency from the target toolchain explicit. This way we can buid from command line a package that use inner-generic-package right after the configuration phase, example: make clean <package-name> Also remove TARGETS_ALL because the only purpose was to add toolchain dependency so it's superseded by this commit. To prevent circular dependency add the new variable <pkgname>_ADD_TOOLCHAIN_DEPENDENCY to avoid adding the toolchain dependency for toolchain packages. This is also a step forward supporting top-level parallel make. Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'toolchain/toolchain-buildroot')
-rw-r--r--toolchain/toolchain-buildroot/toolchain-buildroot.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/toolchain-buildroot/toolchain-buildroot.mk b/toolchain/toolchain-buildroot/toolchain-buildroot.mk
index 2b5028cbb..853baf89f 100644
--- a/toolchain/toolchain-buildroot/toolchain-buildroot.mk
+++ b/toolchain/toolchain-buildroot/toolchain-buildroot.mk
@@ -14,4 +14,6 @@ BR_LIBC = $(call qstrip,$(BR2_TOOLCHAIN_BUILDROOT_LIBC))
TOOLCHAIN_BUILDROOT_DEPENDENCIES = host-gcc-final
+TOOLCHAIN_BUILDROOT_ADD_TOOLCHAIN_DEPENDENCY = NO
+
$(eval $(generic-package))