summaryrefslogtreecommitdiff
path: root/toolchain/toolchain-external
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-10-26 23:47:59 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-10-27 10:41:44 +0200
commit447e9051f32936a3a185af926c7ec394cbd61962 (patch)
tree467829f32d3d6f07ef32709025b8c16296600953 /toolchain/toolchain-external
parent2c877590b3b18df4853989a66378c184713ccd55 (diff)
toolchain-external: install libmvec.so from glibc toolchains
On some architectures (namely x86-64), glibc may provide a libmvec library since glibc 2.22, which programs built with gcc OpenMP support might get linked to. In order for these programs to work on the target, we need to copy this library to the target filesystem. This commit takes care of this for the external toolchain situation. Note that libraries listed in TOOLCHAIN_EXTERNAL_LIBS are silently ignored if they don't exist. Therefore, we don't need to have any condition on the architecture or glibc version. For more details on libmvec, see https://sourceware.org/glibc/wiki/libmvec. Fixes bug #9111. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'toolchain/toolchain-external')
-rw-r--r--toolchain/toolchain-external/toolchain-external.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/toolchain-external/toolchain-external.mk b/toolchain/toolchain-external/toolchain-external.mk
index d3608d082..f7c6a1969 100644
--- a/toolchain/toolchain-external/toolchain-external.mk
+++ b/toolchain/toolchain-external/toolchain-external.mk
@@ -79,7 +79,7 @@ endif # ! no threads
endif
ifeq ($(BR2_TOOLCHAIN_EXTERNAL_GLIBC),y)
-TOOLCHAIN_EXTERNAL_LIBS += libnss_files.so.* libnss_dns.so.*
+TOOLCHAIN_EXTERNAL_LIBS += libnss_files.so.* libnss_dns.so.* libmvec.so.*
endif
ifeq ($(BR2_TOOLCHAIN_EXTERNAL_MUSL),y)